Lightning reports DAV_NOT_DAV for Bedework inbox and outbox

RESOLVED INVALID

Status

Calendar
Provider: CalDAV
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: James Andrewartha, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: 2008090118

Bedework 3.4.1.1 server, I've subscribed to the CalDAV Inbox and Outbox but now they don't load.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to Bedework /ucaldav/user/username/Inbox/
Actual Results:  
Inbox and outbox calendars do not load.

Expected Results:  
Inbox and outbox calendars work without error.

From the error console:

CalDAV: Status 207 on initial PROPFIND for calendar Inbox
CalDAV: Authentication scheme Basic
CalDAV: recv: <?xml version="1.0" encoding="UTF-8" ?>

<multistatus xmlns="DAV:" xmlns:ns3="http://calendarserver.org/ns/" xmlns:ns2="http://www.w3.org/2002/12/cal/ical#" xmlns:ns1="urn:ietf:params:xml:ns:caldav">
  <response>
    <href>/ucaldav/user/jamesa/Inbox/</href>
    <propstat>
      <prop>
        <resourcetype>
          <collection/>
          <ns1:schedule-inbox/>
        </resourcetype>
        <ns3:getctag>20080829T073316Z4</ns3:getctag>
      </prop>
      <status>HTTP/1.1 200 ok</status>
    </propstat>
  </response>
</multistatus>

Warning: There has been an error reading data for calendar: Inbox.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at http://yaminon:8080/ucaldav/user/jamesa/Inbox is either not a DAV collection or not available

The outbox has a similar error.

Comment 1

9 years ago
The in and out boxes are not CalDAV calendar collections (as you can see in the response) and are not something you subscribe to. When a calendar pointed a CalDAV collection is loaded the associated in and out boxes are detected and used automatically. I've tested this with today's build and it works, with Bedework. Starting with today's build, however, the inbox will not be polled to check for invitations unless you set the pref calendar.caldav.sched.enable and restart. Since this is working as designed I'm going to close the bug.
->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.