Detailed information about page resource usage (cpu/memory)

RESOLVED WONTFIX

Status

()

Firefox
General
--
enhancement
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: andreas palsson, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I would like Firefox to display detailed information on cpu/memoru usage per page.
This would help webdesigners and webapplication developers to create slimmed down and fast sites.

Information which would be interesting are;
- page load speed.
- page rendering speed.
- page memory usage.
- page cpu usage (for rendering and currently executing scripts)
- plugin memory usage
- plugin cpu usage

Thanks.

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → NEW
Depends on: 400120, 392351, 323075
Ever confirmed: true
Version: unspecified → Trunk

Comment 1

9 years ago
I think page load speed and page rendering speed would be pretty useless for most users. You can also use Firebug with the YSlow plugin already if you need it. There's also a difference in actual rendering speed and perceived rendering speed.

Memory and CPU usage on the other hand could be useful.

Updated

8 years ago
Duplicate of this bug: 380521
about:memory is filed somewhere, but most of this is Firebug territory, not core app.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 4

8 years ago
Oops, I should have marked bug 380521 as a dup of bug 400120, not of this bug.
You need to log in before you can comment on or make changes to this bug.