QAC - Error navigating Litmus - The requested bug was: NotFound

RESOLVED FIXED

Status

Other Applications
QA Companion
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Steve, Assigned: cmtalbert)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 337139 [details]
Error - The requested bub was: NotFound

I am running Windows XP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.2) Gecko/2008090213 Firefox/3.0.2

I get the following error navigating the Litmus Tab in QAC.
[Javascript Application]
The requested bug was: NotFound

Steps to reproduce
1) Install QA Companion
2) Created a user and log in
3) Navigate to the Litmus tab
4) Select a test case
5) Navigate to each test case and each time the error pops up.

See screenshot.
(Reporter)

Comment 1

10 years ago
I found a work around for people affected by this bug.
1) Reproduce the error and leave the error dialog open.
2) Open another QAC window and use that instead.
(Assignee)

Comment 2

10 years ago
Sounds like an unusual error that prevents people from really using the product. P2
Priority: -- → P2
(Assignee)

Comment 3

10 years ago
Created attachment 349533 [details] [diff] [review]
patch v1

Ok, looks like this happened because we changed the JSON parsing under the covers.  It's now getting back a string where before it was evidently getting back an int.

Code will now handle both cases (firefox 2 & onward).
Assignee: nobody → ctalbert
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Attachment #349533 - Flags: review?(brian)

Comment 4

10 years ago
Comment on attachment 349533 [details] [diff] [review]
patch v1

Speaking of JSON, this will likely be of interest when refactoring commences:

https://developer.mozilla.org/En/Updating_extensions_for_Firefox_3.1#JSON
Attachment #349533 - Flags: review?(brian) → review+
(Assignee)

Comment 5

10 years ago
(In reply to comment #4)
> (From update of attachment 349533 [details] [diff] [review])
> Speaking of JSON, this will likely be of interest when refactoring commences:
> 
> https://developer.mozilla.org/En/Updating_extensions_for_Firefox_3.1#JSON

Indeed that might be an issue, but so far, this patch works on 3.1.  That leaves open a distinct possibility that we aren't using JSON in the "standard" manner, and so might open us to issues down the road.  Or it might mean that we're just not doing anything too terribly complicated with it.  Good chance either way, we should investigate that during the refactoring.

Checked in:
Checking in chrome/content/litmus.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/litmus.js,v  <--  litmus.js
new revision: 1.19; previous revision: 1.18
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.