Closed Bug 453953 Opened 11 years ago Closed 11 years ago

New tab is not opened just after (on the right) of the current one

Categories

(Firefox :: Tabbed Browser, enhancement)

x86
Linux
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 465673

People

(Reporter: dchris, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.1) Gecko/20080528 Epiphany/2.22 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.1) Gecko/20080528 Epiphany/2.22 Firefox/3.0

When opening a new tab (for example with CTRL+T), the new tab is appended so that it is the last one on the right. I think it would be better if the tab was opened just after (on the right) of the current one.

The current bahavior can be very annoying if one has a lot of opened tabs because it forces one to scroll right until one reaches the new tab.

Note that IE7 already made this improvement.

Reproducible: Always

Steps to Reproduce:
1. Open severals tabs
2. Give the focus to any tab except the last one
3. Create a new tab with CTRL+T
Actual Results:  
The new tab is always last in the row

Expected Results:  
The new tab should be opened just after current one for better usability.
Please use an extension such as Tabs Open Relative from <https://addons.mozilla.org/firefox/1956> to get the desired behavior.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 262459
You need to log in before you can comment on or make changes to this bug.