Closed Bug 453978 Opened 12 years ago Closed 11 years ago

Get Firebug 1.4 to work on Firefox 3.5 (was 3.1)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: johnjbarton, Unassigned)

References

(Depends on 1 open bug)

Details

Tracking progress on Firebug 1.3 on Firefox 3.1
Currently we cannot even load Chromebug components.

The nightly build 3.1b1pre falls over on component not available
var appShellService = Components.classes["@mozilla.org/appshell/appShellService;1"].
            getService(Components.interfaces.nsIAppShellService);

I need this to print info on why firebug-http-observer falls over.

Need to try 3.1a2 in case this is just a hiccup on nightly.
Flags: wanted-firefox3.1?
Summary: Get Firebug to work on Firefox 3.1 → Get Firebug 1.3 to work on Firefox 3.1
Whiteboard: [firebug-p3]
1.4 will be the version we want so support on FF3.1

Status: FF3.1b2pre loads Firebug but Chromebug cannot load Firebug because of 465993 and the testcase for 465993 can't run because of 465998 crash.
Depends on: 465993
Flags: blocking-firefox3.1?
Summary: Get Firebug 1.3 to work on Firefox 3.1 → Get Firebug 1.4 to work on Firefox 3.1
There is a workaround for 465998 crash. Chromebug sorta works if you ignore the first zero size window and open a new one from Tools, but it gives errors when you click the tabs. The error message has no information.
Hey John - just like last time, we're not going to block on meta bugs; can you please identify each of the issues blocking Firebug, add them as dependencies of this bug, and nominate them individually for blocking. Thanks.
Flags: wanted-firefox3.1?
Flags: wanted-firefox3.1+
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1-
I've run the eval() debugging test I use for developing the script panel under FF3.1b3pre+Firebug 1.4a11pre  successfully.

I started through a set of tests called "joes-original". Mostly working but found one crasher so far.

I've reviewed the issues reported by users against FF3.1+Firebug and we have one problem with XHR.  this.xhrRequest.onreadystatechange; fails.

Fireunit does not run on FF3.1.

So: need 2 bugzilla reports and we need to get Fireunit debugged on FF3.1
I started tracking down the "loadJSONDebugger" crasher. The test is
http://getfirebug.com/tests/console/joes-original/test.html
"debugger in JSON" button.
It crashes after jsd.enterNestedEventLoop, on a call_enumerate.

I guess it gets to eval(req.responseText); in breakpoints.js
and hits "debugger" triggering the debugger. Somewhere in the debugger UI setup must be an enumerate on a bad object.

and Boris asks why these take so long....
Whiteboard: [firebug-p3] → [firebug-p2]
Depends on: 471066
Added the traceAll() crash 469492 from Manoj.
Depends on: 469492
Whiteboard: [firebug-p2] → [firebug-p1]
In Firefox 3.1 b3 build 1 with Firebug 1.4a12 enabled for the site http://eu.samples.gaiaware.net/AutoCompleter.aspx code from AJAX request will not be executed.

Firebug just breaks AJAX applications.

I don't know if this is related to comment #5, just want to notice that it's reproducible on that page.
Firebug 1.4a12 is pretty out-of-date now. We're working on an a13 with recent fixes, but have quite a few changes to verify.

Firebug-specific functionality should be reported to http://code.google.com/p/fbug/issues. This bug is for firefox-related Firebug errors.
Depends on: 449198
Depends on: 483672
(In reply to comment #8)
> In Firefox 3.1 b3 build 1 with Firebug 1.4a12 enabled for the site
> http://eu.samples.gaiaware.net/AutoCompleter.aspx code from AJAX request will
> not be executed.
> 
> Firebug just breaks AJAX applications.

This is caused by bug 483672.
Depends on: 484459
No longer depends on: 484459
Depends on: 485055
No longer depends on: 485055
This is an update on 16APR09 with Firebug 1.4a19 running on FF3.1b3.

Chromebug crashes on startup with http://crash-stats.mozilla.com/report/index/e547258e-e6df-44db-b16b-20f782090416

With Honza's disabled ShowXHR hack, 20 Firebug FBTests fail vs 9 on FF3.0.8. Most of these are net panel tests that time out so they could all be one issue related to events. console/testErrors.js also fails, but when I try the test manually it works.
how about on latest shiretoko nightly?

can we get a list of the failures paste-binned somewhere or attached here to take a look at them?
Today I built:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090420 Shiretoko/3.5b4pre

Chromebug comes up, progress!

Unfortunately I can't report on FBTest progress. As soon as I hit "Run All" for FBTest window, FF crashes. Just scrolling through the stack it looks like JS_GetScopeChain has gone from crashing on null to blowing the stack on recursion. I see pages of the stack below.

Its possible (but unlikely) that my patch causes this problem. 


 	js3250.dll!JS_GetScopeChain(JSContext * cx=0x07aad3b8)  Line 1802 + 0x39 bytes	C++
 	xpc3250.dll!XPCThrower::ThrowExceptionObject(JSContext * cx=0x07aad3b8, nsIException * e=0x06d3e600)  Line 320 + 0xa bytes	C++
 	xpc3250.dll!XPCThrower::BuildAndThrowException(JSContext * cx=0x07aad3b8, unsigned int rv=2147549183, const char * sz=0x0151005c)  Line 256 + 0x12 bytes	C++
 	xpc3250.dll!XPCThrower::Throw(unsigned int rv=2147549183, JSContext * cx=0x07aad3b8)  Line 57 + 0x11 bytes	C++
 	xpc3250.dll!Throw(unsigned int errNum=2147549183, JSContext * cx=0x07aad3b8)  Line 55 + 0xd bytes	C++
 	xpc3250.dll!XPC_WN_InnerObject(JSContext * cx=0x07aad3b8, JSObject * obj=0x08d53640)  Line 862 + 0xd bytes	C++
 	js3250.dll!JS_GetScopeChain(JSContext * cx=0x07aad3b8)  Line 1802 + 0x39 bytes	C++
 	xpc3250.dll!XPCThrower::ThrowExceptionObject(JSContext * cx=0x07aad3b8, nsIException * e=0x06d3e578)  Line 320 + 0xa bytes	C++
 	xpc3250.dll!XPCThrower::BuildAndThrowException(JSContext * cx=0x07aad3b8, unsigned int rv=2147549183, const char * sz=0x0151005c)  Line 256 + 0x12 bytes	C++
 	xpc3250.dll!XPCThrower::Throw(unsigned int rv=2147549183, JSContext * cx=0x07aad3b8)  Line 57 + 0x11 bytes	C++
 	xpc3250.dll!Throw(unsigned int errNum=2147549183, JSContext * cx=0x07aad3b8)  Line 55 + 0xd bytes	C++
 	xpc3250.dll!XPC_WN_InnerObject(JSContext * cx=0x07aad3b8, JSObject * obj=0x08d53640)  Line 862 + 0xd bytes	C++
 	js3250.dll!JS_GetScopeChain(JSContext * cx=0x07aad3b8)  Line 1802 + 0x39 bytes	C++
is that FBTest inside Chromebug or running it inside Firebug itself?

If you're getting a crash doing this, you should probably file a separate bug. This could also be related to that other JS_GetScopeChain bug 469492.
Depends on: 489378
Summary: Get Firebug 1.4 to work on Firefox 3.1 → Get Firebug 1.4 to work on Firefox 3.5 (was 3.1)
Depends on: 489671
Depends on: 488842
Ok just to give an update: 
   I have workarounds for the crashes.
   The FBTests pass except for testErrors (489671) and all of the net panel tests (483672). We don't know if other net panel failures are being masked.
   Since Firebug 1.4 is in good shape now we can start running on 3.5 routinely.
Depends on: 489255
I changed the priority here to reflect our decision on the Firebug team to invest in jsd2 work for FF 3.6 as the expense of work on FF 3.5. In particular I will stick to FF3.0 for Firebug 1.4 work for now.
Whiteboard: [firebug-p1] → [firebug-p2]
that was not something that was explicitly agreed to in the meeting. Having a version of Firebug that is compatible with Firefox 3.5 is extremely important.
Ok, what I really wanted to say:

This bug includes my updates for Firebug 1.4 working on FF 3.5. Since I want jsd2 to happen and it has to be done on FF 3.6, I am putting my time in that direction. Consequently, since there are only so many hours in each day, I will be focusing my Firebug 1.4 work on FF 3.0. Hopefully someone will take up the FF 3.5 issues, but I don't want to leave the impression (created by my earlier posts) that I am still working on it.

Sorry I did not intend to speak for others.
jjb
Firebug 1.4.0 has been released.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [firebug-p2]
You need to log in before you can comment on or make changes to this bug.