Last Comment Bug 454024 - "ftp:///" (no hostname) gives an empty list of files instead of an error
: "ftp:///" (no hostname) gives an empty list of files instead of an error
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: FTP (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
ftp:///
Depends on: 808313
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-06 17:40 PDT by Jesse Ruderman
Modified: 2012-11-03 15:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (854 bytes, patch)
2010-07-21 13:46 PDT, Tautvydas Andrikys
jduell.mcbugs: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2008-09-06 17:40:28 PDT
1. Load ftp:///

Result: an empty list of files

Expected: an error message telling me that's a bogus URL or something
Comment 1 Matthias Versen [:Matti] 2008-09-06 17:46:18 PDT
I get a blank page and an empty list if i load the the url again but that is bug 406787
Comment 2 Steven Michaud [:smichaud] (Retired) 2008-09-10 16:02:29 PDT
I see this in FF 3.0.1 on OS X, Windows and Linux.  I don't see it in
FF2.

On Linux it always happens (in FF 3.0.1).

But on OS X and Windows I see the following:

1) If I right-click on the ftp:/// URL and choose "open in another
   tab", I get a blank tab.

2) If I just click on the ftp:/// URL I get an empty list of files.

3) And very strangely, once I've performed step 2, even performing
   step 1 now always gives me an empty list of files ... until I
   restart the browser.
Comment 3 Matthias Versen [:Matti] 2008-09-10 16:15:16 PDT
Could you retest with a nightly because bug 406787 could have fixed the empty file list.
Comment 4 Steven Michaud [:smichaud] (Retired) 2008-09-10 16:31:22 PDT
Oops, sorry.

Testing with today's Minefield nightly (on OS X 10.5.4) I no longer
see this problem.  Either nothing happens, or a blank page opens in a
new tab.
Comment 5 Tautvydas Andrikys 2010-07-21 13:46:26 PDT
Created attachment 459136 [details] [diff] [review]
fix
Comment 6 Jason Duell [:jduell] (needinfo me) 2012-01-04 13:28:22 PST
Comment on attachment 459136 [details] [diff] [review]
fix

Review of attachment 459136 [details] [diff] [review]:
-----------------------------------------------------------------

I also get a blank screen with nightly, which is better than an empty file list, but I think the error screen we get when we use this patch is better.  Sorry for taking so long to review this.  I'll take care of landing it.
Comment 7 Jason Duell [:jduell] (needinfo me) 2012-01-04 13:31:09 PST
landed on inbound:

  https://hg.mozilla.org/integration/mozilla-inbound/rev/c3e98453fc95
Comment 8 Marco Bonardo [::mak] 2012-01-05 08:49:13 PST
https://hg.mozilla.org/mozilla-central/rev/c3e98453fc95

Note You need to log in before you can comment on or make changes to this bug.