Closed Bug 454231 Opened 13 years ago Closed 13 years ago

"Password Required" dialog may appear multiple times when restoring session

Categories

(Firefox :: Session Restore, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: zorzella, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

See attached screenshot. This problem seems to have been introduced with FF 3.0. I've never seen this happen with FF 2.0.

Here's what I think the issue is: 

1. When "Master Password" feature is enabled and

2. multiple tabs are open on Firefox startup, and 

3. several of those tabs need a "Master-Password"-protected password to be retrieved

Firefox asks for the master password multiple times, instead of just one. It could be a race condition, or deterministic (not sure about that), but it happens all the time.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
You need to log in before you can comment on or make changes to this bug.