Support outerHTML property

RESOLVED DUPLICATE of bug 92264

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 92264
9 years ago
5 years ago

People

(Reporter: Susurrus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

The outerHTML property is extremely useful in certain circumstances. According to http://www.quirksmode.org/dom/w3c_html.html outerHTML is supported in multiple browsers besides IE, but not in Firefox. While it's not a standard, it might be worth supporting.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Component: General → DOM: Mozilla Extensions
Product: Firefox → Core
QA Contact: general → general
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92264
(Assignee)

Updated

5 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.