Mozilla Firefox Disk Cache is confined to only 8192 objects

RESOLVED DUPLICATE of bug 175600

Status

()

Firefox
File Handling
--
critical
RESOLVED DUPLICATE of bug 175600
9 years ago
9 years ago

People

(Reporter: Abhinav Kumar, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

The disk cache of Mozilla Firefox 3.0 cannot store more than 8192 objects no matter what the maximum disk cache size is.

Mine has set 256 MB (Disk Cache) but it always remains around 80 MB.

And the objects stored never crosses 8192 objects. I think it is the limitation of the _CACHE_MAP_ file which is in plain limited format. As the history has been transformed into sqlite database in Mozilla 1.9 branch. You should store the Cache Map also in sqlite format which is beyond limitation or take off the limit on disk cache like Google Chrome

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 175600
You need to log in before you can comment on or make changes to this bug.