Closed Bug 454576 Opened 13 years ago Closed 13 years ago

TM: JIT content enabled - cannot load Gmail

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9.1b1

People

(Reporter: jmjjeffery, Assigned: brendan)

References

Details

(Keywords: regression, top100, verified1.9.1)

Attachments

(1 file)

With today's nightly build attemtping to log into Gmail shows the loading screen, and the loading go to about  98% it appears, then the browser reports 'Done'.  Gmail never loads.

Turning off JIT Content in about:config allows page to load fully.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080910043000 Minefield/3.1b1pre Firefox/3.0 ID:20080910043000
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080910043000 Minefield/3.1b1pre ID:20080910043000

confirmed

changed to critical because so many "bugpeople" use Gmail.
Severity: major → critical
Flags: blocking1.9.1?
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080910064831 

Seems to be working on here with the latest hourly and JIT enabled.
Blocks: 451602
Target Milestone: mozilla1.9.1b1 → ---
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja; rv:1.9.1b1pre) Gecko/20080910020330 Minefield/3.1b1pre

OS / Platform should be All, since I can confirm this on Mac too.
Confirm not working with Win XP SP3 but only in Gmail Standard view. That is, Basic HTML view is loading correctly.
(In reply to comment #2)
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre)
> Gecko/20080910064831 
> 
> Seems to be working on here with the latest hourly and JIT enabled.

I cannot confirm, still hangs here even after clearing cookies.  

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre)
Gecko/20080910064831 Minefield/3.1b1pre Firefox/3.0 ID:20080910064831
OOps re: comment #4 -forgot my user agent 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080910043000 Minefield/3.1b1pre ID:20080910043000
Seeing these in the Error console (Console2)
Error: this.jt is undefined
Source file: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=9DCpeyGCQEg&am=R_E4pcSXcDHJqgyJ
Line: 336
 ----------
Error: this.B() is undefined
Source file: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=9DCpeyGCQEg&am=R_E4pcSXcDHJqgyJ
Line: 743
 ----------
Error: this.B() is undefined
Source file: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=9DCpeyGCQEg&am=R_E4pcSXcDHJqgyJ
Line: 811
 ----------
Error: %107
Source file: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=9DCpeyGCQEg&am=R_E4pcSXcDHJqgyJ
Line: 573
 ----------
Error: pwa is undefined
Source file: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=9DCpeyGCQEg&am=R_E4pcSXcDHJqgyJ
Line: 573
(In reply to comment #7)
> Seeing these in the Error console (Console2) [snip]

I'm not seeing those either. I doubt it matters but I'm on a 64-bit system if that makes any difference what so ever. GMail is still working here without issue.

No clue what's different for me but I cannot reproduce this at all.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080910075828 Minefield/3.1b1pre (.NET CLR 3.5.30729)
I get the same errors a Littlemutt.  Fails with latest hourly

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080910082744 Firefox/2.0.0.11 ID:20080910082744
Just to be explicit:

Works:
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b1pre)
Gecko/20080909233129 Minefield/3.1b1pre

Doesn't work:
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b1pre)
Gecko/20080910013045 Minefield/3.1b1pre

Ryan, just to check, you do have JIT-for-content enabled, right?
This shows JIT enabled and GMail working in the background for me. In fact I just got the bugmail from there.
FWIW, the problem seems to be just on that initial loading page.

I set browser.preferences.instantApply = true (saved having to restart), toggled JIT-content off to get past the endless load, toggled JIT back on once I got to my inbox, and went on my merry way (so far).

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b1pre) Gecko/20080910043000 Minefield/3.1b1pre - Build ID: 20080910043000
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b1
Confirmed on Linux,

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080911001916 Minefield/3.1b1pre
Duplicate of this bug: 454742
Hardware: PC → All
OS: Windows Vista → All
Confirmed on OS X.
Does anyone have the time to bisect, and find the regressing changeset? I'll get to it later today or tonight if no one else does. Gotta get this fixed.

/be
Assignee: general → brendan
Status: NEW → ASSIGNED
While I indeed know how to spell 'ass-u-me' , I'm pretty confident this broke when the latest merge from TM for JIT occured.  There were several TM bugs that landed in that change set, so its not going to be easy I would guess, but I don't know a thing about code. 

I base this on the number of testers that use Gmail, and it was noted the next nightly after the 'merge' from TM, no one was seeing this before or we would have heard about it I'm sure.
Status: ASSIGNED → NEW
Works in the 09-09-2008 nightly. Broken in the 09-10-2008 nightly.
Works for me now, possibly due to patch for bug 454689 landing on m-c?

/be
I can confirm it works on the new Tinderbox build, tracemonkey-win32/1221174779.
wfm with latest tinderbox build, rev:b0aaf69e714e. A couple after brendan's checkin.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080911164501 Minefield/3.1b1pre ID:20080911164501

Sorry, forgot to add my build-id.
Still broke for me: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080911105329 Firefox/2.0.0.16 ID:20080911105329
(In reply to comment #23)
> Still broke for me: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b1pre) Gecko/20080911105329 Firefox/2.0.0.16 ID:20080911105329

That build doesn't contain the fix for bug 454689. It landed at 2008-09-11 18:35:

http://hg.mozilla.org/mozilla-central/rev/9b5762656489
Keywords: top100
Thanks for letting me know.  Updated to latest hourly and now WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080911212530 Firefox/2.0.0.16 ID:20080911212530
(In reply to comment #22)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre)
> Gecko/20080911164501 Minefield/3.1b1pre ID:20080911164501
> 
> Sorry, forgot to add my build-id.

Where did you get 20080911164501? I only see 20080911105329
WFM using hourly: 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080912024835 Minefield/3.1b1pre Firefox/3.0 ID:20080912024835

Fixed by: https://bugzilla.mozilla.org/show_bug.cgi?id=454689
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080912031847 Minefield/3.1b1pre ID:20080912031847

Verified
Status: RESOLVED → VERIFIED
Depends on: 454689
Keywords: verified1.9.1
Keywords: fixed1.9.1
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.