Last Comment Bug 454749 - Absolute positioned child of -moz-column is incorrectly placed
: Absolute positioned child of -moz-column is incorrectly placed
Status: RESOLVED FIXED
[fixed by bug 10209]
:
Product: Core
Classification: Components
Component: Layout: R & A Pos (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: :Ehsan Akhgari
:
Mentors:
http://www.princexml.com/howcome/2008...
: 687345 (view as bug list)
Depends on: 455338
Blocks: 655191
  Show dependency treegraph
 
Reported: 2008-09-11 00:27 PDT by philippe (part-time)
Modified: 2011-10-07 04:01 PDT (History)
8 users (show)
roc: blocking1.9.1-
roc: wanted1.9.1-
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test case (548 bytes, text/html)
2008-09-11 00:27 PDT, philippe (part-time)
no flags Details
test case 2 (552 bytes, text/html)
2008-09-11 00:46 PDT, philippe (part-time)
no flags Details
Patch (v1) (2.19 KB, patch)
2011-10-06 14:18 PDT, :Ehsan Akhgari
roc: review+
Details | Diff | Splinter Review

Description philippe (part-time) 2008-09-11 00:27:48 PDT
Created attachment 338057 [details]
test case

An absolute positioned child of an element with -moz-column and position:relative is positioned inside the padding-box instead of the border-box.

Affected: Gecko 1.8.1, Gecko 1.9.0, 1.9.1 b1pre
Comment 1 philippe (part-time) 2008-09-11 00:46:45 PDT
Created attachment 338058 [details]
test case 2

With 'right:0;' the element is actually dragged outside of the parent box (by the same amount as the value for padding).
But 'bottom:0;' puts it in the padding-box (vertically)
Comment 2 philippe (part-time) 2008-09-25 17:23:50 PDT
Added the PrinceXML demo page for @fontface in hte URL field. Various examples use absolute positioning and look bad on Gecko.

(the issue is not visible on the equivalent ALA pages, where -moz-column is not specified)
Comment 3 j.j. 2011-09-18 17:12:23 PDT
*** Bug 687345 has been marked as a duplicate of this bug. ***
Comment 4 :Ehsan Akhgari 2011-09-29 15:01:06 PDT
The infrastructure for this has landed in bug 10209.
Comment 5 (mostly gone) XtC4UaLL [:xtc4uall] 2011-09-30 22:02:25 PDT
Both Testcases WFM with Bug 10209 fixed using Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20110930 Firefox/10.0a1 ID:20110930172132 (Built from http://hg.mozilla.org/mozilla-central/rev/325e330499b4)
Comment 6 philippe (part-time) 2011-10-01 04:25:52 PDT
Yeah, works fine now, both attached test cases, the test cases in the duped bug and some others I have on my dev server. Marking as fixed by bug 10209. Thanks Ehsan.
Comment 7 philippe (part-time) 2011-10-01 04:51:27 PDT
@Ms2ger why WFM ? FIXED seems way more appropriate.
Comment 8 :Ehsan Akhgari 2011-10-06 14:11:51 PDT
This is fixed now, I just need to write a reftest for it...
Comment 9 :Ehsan Akhgari 2011-10-06 14:18:43 PDT
Created attachment 565348 [details] [diff] [review]
Patch (v1)
Comment 11 Ed Morley [:emorley] 2011-10-07 04:01:50 PDT
Test: https://hg.mozilla.org/mozilla-central/rev/08d0b387aab3

Note You need to log in before you can comment on or make changes to this bug.