Closed Bug 454855 Opened 16 years ago Closed 14 years ago

Repeated error messages in Error console referring to chrome scripts

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 428602

People

(Reporter: karl.riedling, Unassigned)

Details

(Whiteboard: [CLOSEME 2010-11-01])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

The following error message appears (stochastically ?) in the error console when pages with HTML forms are processed:

Error: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 834"  data: no]

No impact on the actual page can be noticed, though. (However, it is disturbing in getting my own JavaScript code clean. ;-) )

Reproducible: Couldn't Reproduce

Steps to Reproduce:
I tried browsing several pages of the web application I had been working on when the error messages appeared, but I could not provoke the error once more.



Sorry I was not able to reproduce the error. However, since it pertains to an uncaught exception, the reason why the exception occurred is probably less relevant than the fact that it was not caught.
Version: unspecified → 3.0 Branch
This could be a duplicate of bug 428602.
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
The bug still exists in Firefox 3.6.10 (and any preceding 3.x version). It occurs whenever the autocomplete function offers contents for a form field but (different) contents are typed in. It appears not do do any harm to the operation of the browser or the page, but it is extremely tedious during debugging JavaScript code on web pages containing forms.

And, yes, it is apparently a duplicate of bug 428602.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.