Closed Bug 454896 Opened 13 years ago Closed 13 years ago

Sporadic RLk: 84.0B on WINNT 5.2 mozilla-central leak test build - 2008/09/10 13:54:06

Categories

(Core :: General, defect)

x86
Windows Server 2003
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: robert.strong.bugs, Assigned: dholbert)

References

Details

(Keywords: memory-leak, regression)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1221080046.1221081992.1232.gz&fulltext=1

--NEW-LEAKS-----------------------------------leaks------leaks%-----------------------
nsThread                                         72          -
nsRunnable                                       12          -
TOTAL                                            84
Keywords: mlk
Roughly, the relevant window of checkins is:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=Sep+10%2C+2008+8%3A00+&enddate=Sep+10%2C+2008+14%3A00+

with the checkins from 13:00 on being most likely, since the earlier ones were included in a non-leaking build (starting at 10:31)

So, that narrows it to changesets 84e158479b0d, 38140c8a8327, and 78d19b676e11.  

The second checkin (http://hg.mozilla.org/mozilla-central/rev/38140c8a8327, bug 436379) looks particularly suspicious, since it creates a new nsRunnable subclass, and the leak includes an nsRunnable.
Blocks: 436379
So bug 436379 did make a new kind of runnable but it is run synchronously and from an nsRefPtr so I don't see how it could be leaking...
(In reply to comment #2)
> So bug 436379 did make a new kind of runnable but it is run synchronously and
> from an nsRefPtr so I don't see how it could be leaking...

Ok.  I just backed out that bug's changeset (before your comment appeared), so we'll see if that fixes the leak, and if not, we can re-land it.
The backout itself was changeset 713e17a25165 at 18:03 today.

The 8 cycles starting before the backout all had "Rlk: 84.0B", and the 4 cycles since the backout have all had "Rlk: 0B".

So, the backout seems to have fixed this leak.
Assignee: nobody → dholbert
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
semi-unrelated note: this box did have one cycle since this was backed out where it reported RLk:7.14KB.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1221191750.1221193357.11445.gz&fulltext=1

It does appear that the backout fixed the leak since it was very consistently reporting RLk: 84.0B since bug 436379 landed and has not reported RLk: 84.0B since it was backed out.
You need to log in before you can comment on or make changes to this bug.