Classic: New Account Setup is non-functional on Mail app startup

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
P3
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Nikhil Bhatla (gone), Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

18 years ago
Mozilla build from morning of 7/13:

When you launch Mail for the first time after starting up the browser, a New 
Account Setup wizard is displayed.  However, it is non-functional.  All four 
buttons (Cancel, Next, Previous, and Finish) are clickable when only two of them 
should be (Cancel and Next).  

Clicking on "Next" report "Error: missing an entry in the wizard map for null". 

"Back" reports a Javascript Error: "chrome://global/content/wizardHandlerSet.js 
line 83: this.wizardmap[this.currentPageTag] has no properties".

"Finish" reports a Javascript error: 
"chrome://messenger/content/accountWizard.js line 120: 
wizardManager.wizardmap[wizardManager.currentPageTag] has no properties".

"Cancel" works fine.  If you cancel the first Wizard and try it again, the 
buttons work fine.

Comment 1

18 years ago
Mark dogfood if this is truly happening
Severity: normal → major
Keywords: dogfood

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 2

18 years ago
Putting on [dogfood+] radar. 
Whiteboard: [dogfood+]

Comment 3

18 years ago
Do you enter values in each of the fields or make selections prior to clicking 
Next?
(Reporter)

Comment 4

18 years ago
Yeah, I filled out all the proper info on each screen.

Comment 5

18 years ago
this sounds like the onload handler for this dialog is not firing.
CC'ing waterson... this is that same dialog where I was complaining about the 
onload handler not firing last week, bug 44713

Comment 6

18 years ago
what platform is this on, BTW?

Comment 7

18 years ago
oops, just saw the platform/OS field... a Mac bug, yiech. reassigning to 
waterson because he might know what's up with the onload handler (sorry, Chris!)

CC hyatt (for XUL), smfr, pinkerton for some mac expertise.
Assignee: alecf → waterson

Comment 8

18 years ago
-> xptoolkit, to share the wealth.
Assignee: waterson → trudelle

Comment 9

18 years ago
reassigning to danm
Assignee: trudelle → danm
(Reporter)

Comment 10

18 years ago
Still happening on this morning's (7/18) build
(Assignee)

Updated

18 years ago
Whiteboard: [dogfood+] → [dogfood+] new. must pick date this week. eta 21 Jul
(Assignee)

Comment 11

18 years ago
  Alright, we got problems. I've tried to reproduce this with private debug 
builds on the Mac and Windows, as well as with the pre-packaged 2000-07-19-12-M17 
builds, both Mozilla and Netscape, on the Mac.
  Just to be sure, what I'm doing is downloading the .sea.bin file, unstuffing 
it, then deleting my :Documents:Mozilla folder and my :System 
Folder:Preferences:Mozilla Registry file, and finally launching the Mozilla 
Messenger file. I get a completely well-behaved Account Setup Wizard in all 
cases, with disabled Back and Finish buttons.
Whiteboard: [dogfood+] new. must pick date this week. eta 21 Jul → [dogfood+] can't reproduce. no ETA.

Comment 12

18 years ago
Marking WorksForMe...nbaca, please verify.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 13

18 years ago
Build 2000-07-19-20M17, Commercial and Mozilla: Mac 9.04
Verified Worksforme. I followed the steps that danm describes and I don't see 
problems with the Account Wizard buttons.
Status: RESOLVED → VERIFIED

Comment 14

18 years ago
Build 2000-07-19-20M17: Mac 9.04
Reopening

After observinng Nikhil, I am now able to duplicate the problem. The key is 
changing to the Classic theme.

Steps to reproduce:
1. Open Mail using the Modern theme
a. If a mail account already exists then go to step #2.
b. If no mail account exists and the Account Wizard starts then Cancel out of 
the Wizard, then go to #2.
2. Select Edit|Preferences, select Themes
3. Click onto the Classic theme and select the Switch Theme button, OK.
4. Select Edit|Mail/News Account Settings
5. In the Account Settings dialog select the "New Account" button

Actual Results: 
a. Commercial build: Notice that none of the radio buttons are selected. In 
fact, the "Other ISP or email provider" option is gone. The Cancel, Back, Next, 
and Finish buttons all appear enabled. Cancel works but Next does nothing. Back 
and Finish also do nothing.

Workaround: If I select a radio button such as "Existing Mail account" (not 
always required), Cancel out of the Wizard, reopen the Account Wizard, now the 
"Other ISP or email provider" option appears and is selected. The buttons look 
correct so that the Cancel and Next buttons are enabled and the Back and Finish 
buttons are disabled. I can also select the Next button and it progresses to the 
next dialog as expected.

b. Mozilla build: The same problem occurs where no radio button is selected. The 
Cancel, Back, Next and Finish buttons all appear enabled. Only Cancel works. 

Workaround: Select the "Existing Mail" radio button (this isn't always 
required), select Cancel, reopen the Account Wizard and now the buttons look and 
appear to function correctly.

Expected Results: After changing to the Classic theme, the Account Wizard dialog 
should function and appear correctly:
- The "Existing Mail account" radio button should be selected by default. For 
the commercial version the "Other ISP or email provider" radio button should 
also be selected by default.
- The Back and Finish buttons should be disabled
- The Next button should progress to the Identity dialog

Additional Information:
NT4 build 7/19: The problem does not occur.
Linux: Haven't tried yet.
  
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Thanks Ninoschka for nailling down this problem. Now I can see the problem. It just a skin problem with the account 
wizzard dialog. Reassign to myself as Alecf is out for the day (I think)
Assignee: danm → ducarroz
Status: REOPENED → NEW
Whiteboard: [dogfood+] can't reproduce. no ETA. → [dogfood+] ETA: 7/20
Accepting...
Status: NEW → ASSIGNED
sorry, my mistake, sounds like a little bit more serious than just a skin problem as it works well on WinNT and not 
on Mac. Reassign to danm.
Assignee: ducarroz → danm
Status: ASSIGNED → NEW

Updated

18 years ago
Summary: New Account Setup is non-functional on Mail app startup → Classic: New Account Setup is non-functional on Mail app startup

Comment 18

18 years ago
I'd like to add that if any of this crash is caused by the html: widgets in this
wizard, I have the completely reskinned wizard in my tree, but it got
nsbeta2-'ed the other day.
(Assignee)

Comment 19

18 years ago
  Why oh why would a css rule which points to a missing image cause a bug like 
this? An excellent question which I didn't answer. Instead, I've just fixed the 
css rule.
  By the way: I don't see the crash Alec mentions above. On my machine, the 
dialog fails to initialize (the first time it's displayed), and the buttons don't 
really do anything but print error messages when pressed. The corrected css url 
gives up happy buttons, and straightens out the whole dialog. On my machine. Say 
something if your mileage differs.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: [dogfood+] ETA: 7/20 → [dogfood+]

Comment 20

18 years ago
Build 2000-07-25-09M17: NT4, fixed.
Will check the Mac and Linux early Wed 7/26.

Comment 21

18 years ago
Build 2000-07-26-09M17: Mac 9.04, Linux 6.0
Verified Fixed!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.