Closed Bug 455107 Opened 13 years ago Closed 13 years ago

www_openURL and profile manager with multiple profiles, opening associated file types

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 395891

People

(Reporter: bob_r, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Firefox will not open a .htm/.html, or amy other file associated with it, if there are multiple profiles. If you have Firefox running, you can open such files, but you cannot click on a file and use the www_openURL handler to open Firefox and load the file if there is more than one profile. In version 2.x (and 1.x, for that matter) this worked fine; Firefox would simply ask which profile you wanted to use and the proceed to load the file.

To reproduce, all you have to do is create another profile (add -p to the normal firefox startup shortcut). Then click on an html file with either extension, assuming Firefox is the default browser. The program will abend, and then you cannot load it at all unless you reboot or kill the process with task manager. If it is not the default, the same thing happens if you right click the file and choose open with firefox. 

Reproducible: Always

Steps to Reproduce:
1.add profile
2.try to open .htm or other associated file type
3.
Actual Results:  
abended firefox that must be killed off with task manager before firefox can be opened

Expected Results:  
open the profile manager and then the file
OS: Windows 2000 → Windows XP
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395891
You need to log in before you can comment on or make changes to this bug.