download fails silently if target can't be created

VERIFIED DUPLICATE of bug 429827

Status

()

VERIFIED DUPLICATE of bug 429827
10 years ago
10 years ago

People

(Reporter: Marlon.Nelson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 Shiretoko/3.1a2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 Shiretoko/3.1a2

if your "Save files to" preference is/becomes inaccessible, the download fails silently.



Reproducible: Always

Steps to Reproduce:
1. Set your Downloads preference to "Save files to" /
2. Click on a link that will download a file
   -or-
   go to http://download.mozilla.org/?product=shiretoko-alpha2&os=linux&lang=en-US
3. Choose to save the file and click OK
Actual Results:  
Dialog window goes away.  Nothing is downloaded.  No error is reported.

Expected Results:  
Some indication that nothing was downloaded and why not.

I think this also happens in Firefox 3.0.1
(Reporter)

Comment 1

10 years ago
here's an error message i get:

*** exception in validateLeafName: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsILocalFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: file:///home/marlon/Apps/firefox/components/nsHelperAppDlg.js :: anonymous :: line 271"  data: no]
I think this is the same bug as bug 429827, marking as dupe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429827
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.