Theora stream playback stutters or stops.

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: thomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 Shiretoko/3.1a2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 Shiretoko/3.1a2

Playing back an ogg theora+vorbis stream served by icecast 2.3.x will often stutter or stop. It can be restarted by rapidly hitting the play button but audio will be out of sync.

Reproducible: Always

Steps to Reproduce:
1. open URL in Fx3.1a2
2. Hit play
3. wait to see what happens
Actual Results:  
playback stutters and stops

Expected Results:  
continuous uninterrupted playback

It is not an bandwidth issue. The stream goes up to 30kbyte/s whereas I can sustain 2,5MByte/s without problems. It also plays without interruptions in vlc.

I suspect that there is a problem with the buffering strategy. Probably it doesn't work well for real-time streams.

Comment 1

10 years ago
Yes, it's a bug in the buffering strategy, addressed in the refactoring in bug 449159. I'll retest when that lands.
Depends on: 449159
This bug is pretty old, and we've fixed a lot of stuff since then.  Thomas, are you still seeing this bug in current nightly trunk builds?

Comment 3

8 years ago
A bunch of things have been fixed including an entire new Ogg backend since the bug was raised. No feedback was received from comment 2, and I can't duplicate. Assuming fixed by comment 1. Please re-open/refile if it still happens.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.