Places unit test fail with --enable-application=xulrunner

RESOLVED DUPLICATE of bug 447900

Status

()

Toolkit
Places
RESOLVED DUPLICATE of bug 447900
9 years ago
9 years ago

People

(Reporter: glandium, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
This is something I had failing in debian for a while, but didn't verify with vanilla source yet. I just verified this to happen with the firefox 3.0.2 build 5 source tarballs.
When building with ./configure --enable-application=browser --enable-tests, the places unit test all pass, but when building with ./configure --enable-application=xulrunner --enable-tests --disable-javaxpcom, some tests fail:

../../../../_tests/xpcshell-simple/test_places/autocomplete/test_416211.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_416214.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_417798.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_418257.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_422277.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_multi_word_search.js: PASS
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_word_boundary_search.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_360134.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_384228.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_385829.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_388695.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_393498.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_395101.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_395593.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_405938_restore_queries.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_417228-exclude-from-backup.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_417228-other-roots.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_423515_forceCopyShortcuts.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_424958-json-quoted-folders.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_bookmarks.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_livemarks.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_removeItem.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_restore_guids.js: PASS
../../../../_tests/xpcshell-simple/test_places/bookmarks/test_savedsearches.js: PASS
../../../../_tests/xpcshell-simple/test_places/queries/test_abstime-annotation-domain.js: PASS
../../../../_tests/xpcshell-simple/test_places/queries/test_abstime-annotation-uri.js: PASS
../../../../_tests/xpcshell-simple/test_places/queries/test_searchterms-uri.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_000_frecency.js: FAIL
../../../../_tests/xpcshell-simple/test_places/unit/test_000_frecency.js.log:
>>>>>>>
*** test pending
*** test pending
*** test finished
*** running event loop
*** exiting
*** CHECK FAILED: 3 == 4
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: ../../../../_tests/xpcshell-simple/test_places/unit/test_000_frecency.js :: anonymous :: line 260
*** FAIL ***

<<<<<<<
../../../../_tests/xpcshell-simple/test_places/unit/test_317472.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_331487.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_385397.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_399264_query_to_string.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_399264_string_to_query.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_399266.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_399606.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_402799.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_404630.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_405497.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_408221.js: FAIL
../../../../_tests/xpcshell-simple/test_places/unit/test_408221.js.log:
>>>>>>>
*** test pending
*** test pending
*** test finished
*** running event loop
*** exiting
*** CHECK FAILED: 3 == 4
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: ../../../../_tests/xpcshell-simple/test_places/unit/test_408221.js :: anonymous :: line 126
*** FAIL ***

<<<<<<<
../../../../_tests/xpcshell-simple/test_places/unit/test_413784.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_415460.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_415757.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_419731.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_421180.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_425563.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_429505_remove_shortcuts.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_433525_hasChildren_crash.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_adaptive.js: FAIL
../../../../_tests/xpcshell-simple/test_places/unit/test_adaptive.js.log:
>>>>>>>
*** test pending
Test 0 same count, diff rank, same term; no search
*** test pending
*** test finished
*** running event loop
Test 1 same count, diff rank, same term; no search
*** test pending
*** test finished
Test 2 diff count, same rank, same term; no search
*** test pending
*** test finished
Test 3 diff count, same rank, same term; no search
*** test pending
*** test finished
*** exiting
*** CHECK FAILED: http://site.tld/1 == http://site.tld/2
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: ../../../../_tests/xpcshell-simple/test_places/unit/test_adaptive.js :: anonymous :: line 128
*** FAIL ***

<<<<<<<
../../../../_tests/xpcshell-simple/test_places/unit/test_annotations.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_browserhistory.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_download_history.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_dynamic_containers.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_exclude_livemarks.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_expiration.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_favicons.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_frecency.js: FAIL
../../../../_tests/xpcshell-simple/test_places/unit/test_frecency.js.log:
>>>>>>>
*** test pending
Test 0: same count, different date
*** test pending
*** test finished
*** running event loop
*** exiting
*** CHECK FAILED: http://site.tld/2 == http://site.tld/1
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: ../../../../_tests/xpcshell-simple/test_places/unit/test_frecency.js :: anonymous :: line 130
*** FAIL ***

<<<<<<<
../../../../_tests/xpcshell-simple/test_places/unit/test_history_autocomplete_tags.js: FAIL
../../../../_tests/xpcshell-simple/test_places/unit/test_history_autocomplete_tags.js.log:
>>>>>>>
*** test pending
Searching for 'foo'
*** test pending
*** test finished
*** running event loop
*** exiting
*** CHECK FAILED: 3 == 4
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: ../../../../_tests/xpcshell-simple/test_places/unit/test_history_autocomplete_tags.js :: anonymous :: line 129
*** FAIL ***

<<<<<<<
../../../../_tests/xpcshell-simple/test_places/unit/test_history.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_history_sidebar.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_isvisited.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_markpageas.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_multi_queries.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_multi_word_tags.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_nsINavHistoryViewer.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_placeURIs.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_resolveNullBookmarkTitles.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_result_sort.js: PASS
../../../../_tests/xpcshell-simple/test_places/unit/test_tagging.js: PASS
make[1]: *** [check] Error 1
(Reporter)

Comment 1

9 years ago
It (fortunately) seems to only be a matter of preferences, as copying dist/bin/default/pref/firefox.js from the firefox build info xulrunner's dist/bin/default/pref make the unit test suite pass. I'll try to find out what preferences make the difference.
(Reporter)

Comment 2

9 years ago
Well, that was quite easy: places.frecency.*
(Reporter)

Comment 3

9 years ago
So, it looks like to me these prefs should either be added to xulrunner.js or to the greprefs. What's your take ?
(Reporter)

Comment 4

9 years ago
autocomplete/test_417798.js also sometimes fails when browser.bookmarks.sort.resource is not set. (but sometimes doesn't...)

FWIW, here is the error message:
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_417798.js: FAIL
../../../../_tests/xpcshell-simple/test_places/autocomplete/test_417798.js.log:
>>>>>>>

Adding page/book/tag: 0, 0, , , , 
uri=http://abc/def, 
title=Title with javascript:

Adding page/book/tag: 1, 0, , , , 
uri=javascript:5, 
title=Title with javascript:
*** test pending


*** test pending
../../../../_tests/xpcshell-simple/test_places/autocomplete/head_autocomplete.js:211: strict warning: reference to undefined property 3
0: Match non-javascript: with plain search
Searching for.. a
*** test finished
*** running event loop
Looking for http://abc/def, Title with javascript: in expected results...
Got it at index 0!!
Looking for javascript:5, Title with javascript: in expected results...
*** exiting
*** CHECK FAILED: Didn't find the current result (javascript:5, Title with javascript:) in expected: 
JS frame :: ../../../../tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: ../../../../_tests/xpcshell-simple/test_places/autocomplete/head_autocomplete.js :: anonymous :: line 123
*** FAIL ***

<<<<<<<
(Reporter)

Comment 5

9 years ago
Actually, it just randomly fails...
Sounds like a dupe of bug 447900.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447900
You need to log in before you can comment on or make changes to this bug.