Context menu for toolbars

RESOLVED FIXED

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: Blake Ross, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Would be nice to have a context menu appear upon right clicking on the 
toolbars, like IE has, to quickly show or hide toolbars. It would be pretty 
easy to implement since it could just broadcast off of the View | Toolbars > 
child menu.  Probably not for this release, though.

Comment 1

18 years ago
right on both counts.  accepting for future
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

17 years ago
Is this really Toolkit/Widgets? Seems like XPApps/GUI ...
(Reporter)

Comment 3

17 years ago
Probably, yeah.

Anyways, I have a simple fix for this which just uses the context menu for the 
toolbar.  Elements that shouldn't have it (like the URL bar) have context="".  
It works fine and there's probably no risk involved.

HOWEVER..

I understand and agree with Peter's feelings about checking stuff like this 
into the tree at this point.  So I'm fully willing to just get this into the 
mozilla tree, at his discretion.
Assignee: trudelle → blakeross
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets → XP Apps: GUI Features

Comment 4

17 years ago
Not my discretion, its up to the correct module owner, either xpapps or my
toolkit peer owners, and either brendan or waterson.  
(Reporter)

Comment 5

17 years ago
OK. Don?
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Priority: P3 → P2
Target Milestone: Future → mozilla0.9
(Reporter)

Comment 6

17 years ago
pushing out until we figure out the plans for toolbar customization context 
menus (a la 5.0)
Priority: P2 → P5
Target Milestone: mozilla0.9 → Future

Comment 7

17 years ago
If you are reusing the toolbars submenu, it should automatically get any 
`Customize Toolbars ...' item that is added in the future, shouldn't it?
(Reporter)

Comment 8

17 years ago
No, there will be button-specific context menus like MozClassic.

Comment 9

17 years ago
Oh no there shouldn't be. If I bring up the context menu in the toolbar area, I 
want to do stuff with the toolbar area as a whole, not the individual button 
which I happen to be on at the time.

Using context menus to add/edit/remove individual buttons would be much more
time-consuming than editing the toolbar in a dialog created expressly for that 
purpose.
(Reporter)

Comment 10

17 years ago
There could/would be a customize dialog also.  But I found the inline editing 
in Classic to be very cool.  Anyways, that should be discussed with ben, or in 
another bug.
(Reporter)

Comment 11

17 years ago
giving to ben, if he wants to do this with his other toolbar work.
Assignee: blakeross → ben
Status: ASSIGNED → NEW
Priority: P5 → --
Target Milestone: Future → ---
Netscape nav triage team: as per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-

Comment 13

17 years ago
Mozilla 1.0 nomination.
Keywords: mozilla1.0

Comment 14

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Comment 15

17 years ago
*** Bug 88582 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Priority: -- → P4

Comment 16

16 years ago
*** Bug 117300 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
I don't understand what's holding this back.
Can we not simply make right clicking on any area that would not otherwise bring 
up a context menu to bring up a menu with the contents of the Show/Hide menu?

This sounds like it would be easy to implement quickly.  If in the future there 
is a modification to add a customize toolbars item, that can be dealt with then. 
 When or if that comes in to existence is a mystery to me however.

I can only see this as a win on the user friendlyness side and dropping it in 
before 1.0 would give it a chance to flush out any quirks in advance.

Comment 18

16 years ago
adding self to cc list

Comment 19

15 years ago
I also want to see this implemented.  The context menu should also have a
general "Customize Toolbars" or "Customize Theme" option at the bottom that
would take the user straight to the "Themes" area of the Preferences Dialog...

Updated

15 years ago
Summary: [RFE] Context menu for toolbars → Context menu for toolbars
Product: Core → Mozilla Application Suite
Assignee: bugs → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
QA Contact: jrgmorrison → guifeatures
Target Milestone: Future → ---

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Comment 20

9 years ago
Toolbar context menus is being implemented in Bug 428216
"Customize Toolbars" context menu option is being implemented in Bug 394288
Depends on: 428216, 394288

Comment 21

9 years ago
Hide/Collapse/Expand should probably be on there as well...

Comment 22

9 years ago
Fixed by patch in Bug 428216

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.