Closed Bug 455813 Opened 12 years ago Closed 12 years ago

Windows PGO builds fail when --disable-tests is set

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1b1

People

(Reporter: RyanVM, Assigned: mayhemer)

Details

Attachments

(1 file, 1 obsolete file)

With tests disabled, I get the following error when trying to do a PGO-enabled build with VC8SP1.

OBJDIR=/c/mozbuild/mozilla/objdir-fx python /c/mozbuild/mozilla/objdir-fx/_profile/pgo/profileserver.py
Traceback (most recent call last):
  File "c:/mozbuild/mozilla/objdir-fx/_profile/pgo/profileserver.py", line 40, in <module>
    PROFILE_DIRECTORY, ())
  File "c:\mozbuild\mozilla\objdir-fx\_profile\pgo\automation.py", line 389, in runApp
    certificateStatus = fillCertificateDB(profileDir)
  File "c:\mozbuild\mozilla\objdir-fx\_profile\pgo\automation.py", line 360, in fillCertificateDB
    status = Process(certutil, ["-N", "-d", profileDir, "-f", pwfilePath], environment()).wait()
  File "c:\mozbuild\mozilla\objdir-fx\_profile\pgo\automation.py", line 82, in __init__
    stdin = inputfile)
  File "c:\mozbuild\python\lib\subprocess.py", line 593, in __init__
    errread, errwrite)
  File "c:\mozbuild\python\lib\subprocess.py", line 815, in _execute_child
    startupinfo)
WindowsError: [Error 2] The system cannot find the file specified
make: *** [profiledbuild] Error 1
Right, so the PGO script uses automation.py, which now expects to have certutil available, which only gets built enable-tests, so this is busted.
Hmm... It looks like we need an option to turn of reference to ssl support when build is not tests-enabled. Other option (IMHO better) is to build certutil/pk12util also when this is PGO build.

Which option is more convenient?
You can't detect if it's a PGO build, so you'd have to build it unconditionally, but I'm ok with either approach.
And what about MOZ_PROFILE_USE ?
That gets set after the script is run (in the second pass). Ok, I lied, there is MOZ_PROFILE_GENERATE, but in general, we should make automation.py work even if --disable-tests is specified.
Attached patch fix v1 [Backout: Comment 10] (obsolete) — Splinter Review
With this fix "make -f client.mk profiledbuild" passes. Tested just on winxp. Tomorrow will try on mac.
Assignee: nobody → honzab
Status: NEW → ASSIGNED
Attachment #339380 - Flags: review?(ted.mielczarek)
On mac confirmed too.
I can confirm that this patch fixed it for me.
Attachment #339380 - Flags: review?(ted.mielczarek) → review+
Keywords: checkin-needed
Comment on attachment 339380 [details] [diff] [review]
fix v1
[Backout: Comment 10]

http://hg.mozilla.org/mozilla-central/rev/9841b5e5cf10
Attachment #339380 - Attachment description: fix v1 → fix v1 [Checkin: Comment 9]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b1
Comment on attachment 339380 [details] [diff] [review]
fix v1
[Backout: Comment 10]

This caused
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1222230434.1222232908.30952.gz
Win2k3 comm-central dep unit test on 2008/09/23 21:27:14
{
Traceback (most recent call last):
  File "runtests.py", line 17, in <module>
    import automation
  File "d:\builds\slave\comm-central-win32\build\objdir\mozilla\_tests\testing\mochitest\automation.py", line 43
    IS_TEST_BUILD = 
                   ^
SyntaxError: invalid syntax
}

Backout:
http://hg.mozilla.org/mozilla-central/rev/6e6ac7a9540d
http://hg.mozilla.org/mozilla-central/rev/7c8d3d111429
Attachment #339380 - Attachment description: fix v1 [Checkin: Comment 9] → fix v1 [Backout: Comment 10]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #10)
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1222230434.1222232908.30952.gz
> Win2k3 comm-central dep unit test on 2008/09/23 21:27:14

and
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1222231212.1222234157.1273.gz
Linux comm-central dep unit test on 2008/09/23 21:40:12
and
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1222232271.1222234298.1629.gz
WINNT 5.2 mozilla-central qm-win2k3-moz2-01 dep unit test on 2008/09/23 21:57:51
and
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1222233420.1222235296.4214.gz
WINNT 5.2 mozilla-central qm-win2k3-03 dep unit test on 2008/09/23 22:17:00

Not comm-central specific then.
I remember we have already had this problem in the past. build/pgo/automation.py.in must be touched in all trees, because tinderboxes don't perform a full build and just changing Makefiles that re-generates automation.py is not enough.

I will add some dummy change to the automation.py.in file and let's check in again.

Sorry, I completely forgot about this issue.
Oops, mistake is elsewhere. I messed up name of the variable in mochitest/Makefile.in. This is fixed and tested patch.
Attachment #339380 - Attachment is obsolete: true
Attachment #340111 - Flags: review?(ted.mielczarek)
Attachment #340111 - Flags: review?(ted.mielczarek) → review+
Keywords: checkin-needed
Comment on attachment 340111 [details] [diff] [review]
fix v2
[Checkin: Comment 15]

http://hg.mozilla.org/mozilla-central/rev/48f9681b965c
Attachment #340111 - Attachment description: fix v2 → fix v2 [Checkin: Comment 15]
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.