Closed Bug 455823 Opened 11 years ago Closed 11 years ago

Icon missing from SeaMonkey executable

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: mcsmurf)

Details

(Keywords: regression)

Attachments

(1 file)

In recent SeaMonkey 2.0a1pre builds (most likely after bug 447637 was checked in), the default icons for HTML files and URL shortcuts associated with SeaMonkey were changed to point to the second icon index in the SeaMonkey executable (seamonkey.exe,1) instead of chrome\icons\default\html-file.ico.  The problem is that while firefox.exe contains both the app icon and an HTML page icon, seamonkey.exe only contains the app icon, which causes the filetypes mentioned above to use the default Windows icon instead of the expected icon.
Assignee: build-config → installer
Component: Build Config → Installer
QA Contact: build-config → xpi-packages
Working on this.
Assignee: installer → bugzilla
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
This adds a new member var with the path to the SeaMonkey folder. That way we can add a generic var to the default icon path which is then replaced. Also .eml and .html files then get a generic SeaMonkey file icon, not the SeaMonkey logo itself as icon.
Attachment #339309 - Flags: review?(bugzilla)
Thank you for looking into this.  Your patch fixes the problem, but to be more consistent with other Toolkit apps, do you think it would be a good idea to embed the file icon into the .exe file like Firefox and XULRunner do instead?  I'm not very familiar with build-related code, but it seems to be done by adding an IDI_DOCUMENT line to app/splash.rc:

http://hg.mozilla.org/comm-central/file/tip/suite/app/splash.rc
http://hg.mozilla.org/mozilla-central/file/tip/browser/app/splash.rc
http://hg.mozilla.org/mozilla-central/file/tip/xulrunner/app/splash.rc
I actually think our feature of enabling people to swap the icons is a good thing...
Good point, I hadn't thought of that.
Comment on attachment 339309 [details] [diff] [review]
Patch

Wanted for the Alpha, if possible.
Attachment #339309 - Flags: review?(bugzilla) → review?(neil)
Attachment #339309 - Flags: review?(neil) → review+
Attachment #339309 - Flags: approval-seamonkey2.0a1?
Comment on attachment 339309 [details] [diff] [review]
Patch

Risk: Quite low, this only changes the DefaultIcon entry in the installer code. Before users got the default Windows file icon for .eml and .html, with this patch they get the file icon provided by SeaMonkey
Comment on attachment 339309 [details] [diff] [review]
Patch

a=me for a1, please check in ASAP but of course care that tree is green after today's mess.
Attachment #339309 - Flags: approval-seamonkey2.0a1? → approval-seamonkey2.0a1+
Pushed to c-c, changeset 580ea3dd210c.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.