Closed Bug 455964 Opened 11 years ago Closed 11 years ago

IMAP parser assertions since autosync turnon

Categories

(MailNews Core :: Backend, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: dmose, Assigned: Bienvenu)

References

Details

(Whiteboard: [has reviewed patch, needs landing])

Attachments

(1 file)

###!!! ASSERTION: most recent message has 0 or negative size: 'fDownloadingHeaders || fSizeOfMostRecentMessage > 0', file /Users/dmose/s/comm-central-trunk/src/mailnews/imap/src/nsImapServerResponseParser.cpp, line 3242
###!!! ASSERTION: syntax error in generic parser: '!error', file /Users/dmose/s/comm-central-trunk/src/mailnews/imap/src/nsIMAPGenericParser.cpp, line 92
Flags: blocking-thunderbird3+
Whiteboard: [needs analysis]
Blocks: 436615
Keywords: regression
I get this assertion occasionally. Per IRC conversation with bienvenu, this is a sign of an important parser problem, and should be addressed.
well, a sign of a possibly important problem...I doubt the problem is actually in the parser, but more likely the code that calls the parser.
nsImapProtocol or nsImapIncomingServer?
more likely nsImapProtocol, but since I don't know what's causing the problem, I can't really give you a definitive answer.
It appears that Cyrus 2.3.9 is, in fact, returning a zero-length message.  We should be dealing with that more robustly and not asserting.
Can you try this, Dan?
Assignee: bugmil.ebirol → bienvenu
This does make the assertion go away.
Attachment #339873 - Flags: superreview?(dmose)
Attachment #339873 - Flags: review?(dmose)
Comment on attachment 339873 [details] [diff] [review]
proposed fix for one case Dan is seeing - checked in.

ok, it would be good to land this to get rid of this noise, and then figure out how to deal with avoiding getting these headers in the db completely.
Comment on attachment 339873 [details] [diff] [review]
proposed fix for one case Dan is seeing - checked in.

r+sr=dmose
Attachment #339873 - Flags: superreview?(dmose)
Attachment #339873 - Flags: superreview+
Attachment #339873 - Flags: review?(dmose)
Attachment #339873 - Flags: review+
Keywords: regression
Whiteboard: [needs analysis] → [has reviewed patch, needs landing]
Attachment #339873 - Attachment description: proposed fix for one case Dan is seeing → proposed fix for one case Dan is seeing - checked in.
moving the rest off to b2
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0b2
I haven't seen this in a while, and the patch was landed, so I'm marking this fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.