TM: Gmail spell checker crashes Firefox [@ nanojit::LIns::isop(nanojit::LOpcode) ]

RESOLVED DUPLICATE of bug 454958

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 454958
10 years ago
7 years ago

People

(Reporter: Gabriel Chadwick, Unassigned)

Tracking

({crash, top100})

Trunk
x86
Windows Vista
crash, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
Gmail spell checker crashes Firefox when clicking on the I am finished button. JIT needs to enabled.

To reproduce :

1. Login to Gmail
2. Visit url https://mail.google.com/mail/#compose
3. Click on the spell checking link
4. Click on the I am finished link
5. I hope you have your parachute on :

http://crash-stats.mozilla.com/report/pending/94d786dc-866b-11dd-b25f-001321b13766
http://crash-stats.mozilla.com/report/pending/aba2bde6-866b-11dd-a425-001cc45a2c28
http://crash-stats.mozilla.com/report/pending/4084701c-866c-11dd-bfc1-001cc45a2ce4

With build Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1b1pre) Gecko/20080918073230 Minefield/3.1b1pre
Flags: wanted1.9.1?
Flags: blocking1.9.1?
0  	js3250.dll  	nanojit::LIns::isop  	 js/src/nanojit/LIR.h:343
1 	js3250.dll 	isi2f 	js/src/jstracer.cpp:290
2 	js3250.dll 	isPromoteInt 	js/src/jstracer.cpp:353
3 	js3250.dll 	TraceRecorder::writeBack 	js/src/jstracer.cpp:1381
4 	js3250.dll 	TraceRecorder::set 	js/src/jstracer.cpp:1411
5 	js3250.dll 	TraceRecorder::record_LeaveFrame 	js/src/jstracer.cpp:3758
6 	xul.dll 	XPC_WN_Helper_NewResolve 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1068
7 	js3250.dll 	js_LookupPropertyWithFlags 	js/src/jsobj.cpp:3393
Keywords: regression
Summary: TM: Gmail spell checker crashes Firefox → TM: Gmail spell checker crashes Firefox [@ nanojit::LIns::isop(nanojit::LOpcode) ]
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454958
(Reporter)

Comment 3

10 years ago
Did I just file a dupe of one of my own bugs...
Flags: wanted1.9.1?
Flags: blocking1.9.1?
sure, i used your email as search term to find the dupe :-)
Crash Signature: [@ nanojit::LIns::isop(nanojit::LOpcode) ]
You need to log in before you can comment on or make changes to this bug.