Closed Bug 456091 Opened 11 years ago Closed 11 years ago

Flash Crashes on Fennec

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0b1

People

(Reporter: dougt, Unassigned)

References

()

Details

Load a swf file:
http://people.mozilla.org/~dougt/flash_test.swf

it will crash fennec.

he program 'fennec' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 21749 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Assignee: nobody → doug.turner
Cannot reproduce it with fix from 454756.
Could you check it also?
yeah, with 454756 i can repo.

load the url above two or 3 times.
then load about:plugins.
YEp, I got crash also... but it reproducible only with fennec... with normal browser (based on the same gecko trunk) it works fine.
i can reproduce with TestGtkEmbed using the same XR that Fennec is using.  stacktrace is useless.
Flags: blocking-fennec1.0+
Target Milestone: --- → Fennec A2
There is the something really wrong with osso_initialize, playback and friends in that configuration...

First time I was testing on Microb2 engine (latest trunk + some patches)  and it is not reproducible there..
https://garage.maemo.org/svn/browser/mozilla/trunk/microb-engine/

We need out figure out why and what is different there.
Assignee: doug.turner → pavlov
Assignee: pavlov → nobody
Depends on: 442109
Target Milestone: Fennec A2 → Fennec A3
I haven't seen this in quite a while
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
for beta2 and beta3 we tested with flash on maemo.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.