function returns uninitialized variable

VERIFIED DUPLICATE of bug 45623

Status

NSPR
NSPR
P3
normal
VERIFIED DUPLICATE of bug 45623
18 years ago
18 years ago

People

(Reporter: Marcello Nuccio, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm not sure if it is a bug, but in file
"/cvsroot/mozilla/nsprpub/pr/src/md/unix/uxshm.c", function
"_md_ImportFileMapFromString()" returns "fm" without initializing it in case of
error.

 I have fixed this assigning a default NULL value tu "fm", because this is the
value expected in case of error.

Comment 1

18 years ago
Looks like the bug was reported twice.

*** This bug has been marked as a duplicate of 45623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
Verified that the bug is a duplicate of bug #45623.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.