Lots of password protected tabs cause LOTS of password popup

VERIFIED DUPLICATE of bug 356097

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 356097
9 years ago
9 years ago

People

(Reporter: peter gervai, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 Iceweasel/3.0.0.1 FireFox/3.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2) Gecko/20080829071937 

50 tabs opened, 40 using http auth or remembered login pw, all of them master password protected. At startup/restore I get a password prompt while firefox is still _very_ busy (and in the next minute or so) retrieving the other 45 tabs, so I may or may not be fast enough to type password before...

..another popoup asks for the master password. Then another. GOTO 1

I figured out the trick: I answer ONE of them, try to cancel others and try to click OK on empty auth forms, they retry later, and sometimes they got that pw is known and offer the credentials. It usually takes 2-4 minutes to get rid all the popups and figure out the order of the popups to cancel. Its really a great game, thanks. ;-)


Reproducible: Always

Steps to Reproduce:
1. Have lots of tabs requiring master pw to upen up
2. Crash
3. Restore session, type slowly
Actual Results:  
I will attach a picture.

Expected Results:  
One master password popup, and others should get in the bloody line and wait until I type the password. (I mean, what mutexes are for?)

Just kidding. It's not a great game. It used to be the first few times, but now...
(Reporter)

Comment 1

9 years ago
Created attachment 339825 [details]
The result which would have been great to avoid.

A picture tells a thousand words.
(Reporter)

Comment 2

9 years ago
Additional info: shiretoko alpha 2, addons disabled. (Which made me froze with awe seeing the amount of ads and other flashy sh*t without adblock and noscript. Try sometimes, fellas, truly amazing.)
Version: unspecified → Trunk
(Reporter)

Comment 3

9 years ago
Oh and this has been going on in older versions, too. (2.xx, 3.xx) I thought I've already reported it but didn't find it, so either I search pretty lame or I forgot to send the report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356097

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.