Closed Bug 456482 Opened 12 years ago Closed 11 years ago

Editing "Folder" field in a bookmarks does not create folders for bookmarks

Categories

(Firefox for Android Graveyard :: Bookmarks, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0b1

People

(Reporter: abillings, Assigned: mfinkle)

References

Details

(Keywords: uiwanted)

If a user adds a bookmark in Fennec and then edits it, they can edit a field in the bookmark labeld "Folder:". Editing this field has no effect, though it stores the value. If a value is put for Folder and then the user looks at the bookmark list via the button for that next to the address bar, the bookmark will be in the same flat list as any other bookmarks. No folders are created.

This was seen in Stuart's build 20080918185520.

Steps to Reproduce
1. Open a page
2. On the right panel, select the star.
3. On the right panel, select the star again to bring up the dialog for editing the bookmark properties.
4. Enter a value for the "Folder" field and click on "Done"
5. Open the bookmark list.

Result: Bookmark is in the list with all other bookmarks. No folders are created.
Assignee: nobody → enndeakin
Flags: blocking-fennec1.0+
Target Milestone: --- → Fennec A2
We need to decide how the folders will even be used. Currently, Fennec treats bookmarks in a flat manner. Implementing the folder stuff will require some UI changes.

We could drop "folders".
Keywords: uiwanted
in the latest builds, the value does not persist in the folder text field.  This is in 20081015132834 (xulrunner & fennec)
Duplicate of this bug: 465290
Depends on: 467670
Blocks: 467670
No longer depends on: 467670
Target Milestone: Fennec A2 → Fennec A3
Assignee: enndeakin → mark.finkle
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.