get rid of Windows stat cache

REOPENED
Unassigned

Status

()

defect
REOPENED
11 years ago
8 years ago

People

(Reporter: jaas, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
This is the Windows part of bug 307815, we don't have to remove stat caches for all platforms at the same time. Our current stat caches are fundamentally flawed, we should remove them.
(Reporter)

Updated

11 years ago
Blocks: 307815
No longer depends on: 456435
(Reporter)

Comment 1

11 years ago
Posted patch fix v1.0Splinter Review
Basic try server run shows no significant perf impact, we'll see better numbers when this lands on trunk.
Attachment #340064 - Flags: review?(doug.turner)
Attachment #340064 - Flags: review?(doug.turner) → review+
(Reporter)

Updated

11 years ago
Attachment #340064 - Flags: superreview?(doug.turner)
Comment on attachment 340064 [details] [diff] [review]
fix v1.0

drop the braces for one liners.

     if (aFileSize != -1 && SetEndOfFile(hFile))
     {
-        MakeDirty();
         rv = NS_OK;
     }




assuming that this does not cause any performance regression as mentioned in bug 307815, this is fine.
Attachment #340064 - Flags: superreview?(doug.turner) → superreview+
(Reporter)

Comment 3

11 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

11 years ago
backed out because of tbox issues, not necessarily anything wrong with the patch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This might have caused a performance regression on Tp on Vista (some 30% increase). It is confusing though since the first talos runs also supposedly included the backout, but Tp consistently went up on all 4 Vista talos machines then back down again one cycle later. This was the only patch liable to have impacted, but not sure what is going on. Might be good to land in a quiet tree next time.
(Reporter)

Comment 6

11 years ago
Posted file windows errors
this is a text file containing the unit test errors that came up
(Reporter)

Updated

10 years ago
Assignee: joshmoz → nobody
You need to log in before you can comment on or make changes to this bug.