raising Thunderbird window (from hide) with Lightning enabled is very slow

RESOLVED DUPLICATE of bug 501302

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 501302
10 years ago
8 years ago

People

(Reporter: Linus Kamb, Unassigned)

Tracking

({perf})

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2) Gecko/2008091618 Firefox/3.0.2
Build Identifier: Thunderbird version 2.0.0.16 (20080707), Lightning 0.9

With Lightning plug-in enabled in thunderbird, bringing up the thunderbird window is very slow.  With Lightning version 0.8, this took approximately 2 seconds (compared to essentially instantaneously without.)  With Lightning version 0.9, it now takes approximately 5 seconds to raise the window!

Reproducible: Always

Steps to Reproduce:
1. install Lightning add on
2. subscribe to calendars
3. hide Thunderbird window (not minimize!)
4. click thunderbird icon in task tray (or whatever it's called) to raise window.
5. approximately 5 seconds later, the window appears.
Actual Results:  
window appears eventually

Expected Results:  
window should appear "immediately"

running 10.5.5 on mac pro 2x2.66GHz dual xeon, 5GB of memory

Comment 1

10 years ago
I think this may be related to my bug. 

https://bugzilla.mozilla.org/show_bug.cgi?id=462283

Lightning goes over 50% CPU for simply moving the mouse over the TB window, and often saturates the CPU to 100% when editing and refreshing iCals. When this happens the PC locks up, and all apps stop. Shared iCals is the future for TB, so I would suggest that this speed issue is pretty important.


Does anybody have any ideas why this is happening?
Keywords: perf
This bug just described a symptom of bad performance rendering the calendar view. Any suggestions which bug, that describes the reason for the user experience, to mark this duplicate of?
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501302
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.