"Show image" context menu doesn't work when "Load images automatically" is OFF

RESOLVED DUPLICATE of bug 417545

Status

()

defect
RESOLVED DUPLICATE of bug 417545
11 years ago
11 years ago

People

(Reporter: mikha.crimson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

See "steps to reproduce"
1. Open preferences dialog, uncheck "Content\Load images automatically" checkbox.
2. Load any web page that contains images - there are placeholders instead of images (that's OK as images should not be loaded after (1) )
3. Right-click on image placeholder, select "Show Image" - NO EFFECT.

If before (3) you make "Load images automatically" checked back (but don't reload page), and once again do (3) - it works now.

Reproducible: Always

Steps to Reproduce:
1. Open preferences dialog, uncheck "Content\Load images automatically" checkbox.
2. Load any web page that contains images - there are placeholders instead of images (that's OK as images should not be loaded after (1) )
3. Right-click on image placeholder, select "Show Image"
Actual Results:  
No image shown.

Expected Results:  
Loaded image.

If before step (3) (from "Steps to Reproduce" section) you make "Load images automatically" flag checked back (but don't reload the page that was opened on step(2) ), and redo (3) - it works now (right-clicked image loaded)

Comment 1

11 years ago
Confirming. Moving out of "General" grave to "tabbed browser" component. Not a perfect match, but some code interfaces with browser.js (through context menu) and i didnt find a better component :-P ...

This is also reported in Ubuntu as https://launchpad.net/bugs/294712.

Verified that this bug still exists in latest mozilla-central as of today (the "Show Menu" context menu entry is called "Reload Image").
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browser
Ever confirmed: true
QA Contact: general → tabbed.browser
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417545
You need to log in before you can comment on or make changes to this bug.