Should not show a tooltip for TABLE SUMMARY

VERIFIED FIXED

Status

SeaMonkey
UI Design
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: roc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] (py8ieh:update spec), URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
(Not tested; based on comments in bug 27828.)

Currently, a TABLE element has its SUMMARY attribute shown as a tooltip.

However, the HTML 4.01 spec says
<http://www.w3.org/TR/html4/struct/tables.html#adef-summary>:
|
| summary = text [CS] 
|     This attribute provides a summary of the table's purpose and structure for
|     user agents rendering to non-visual media such as speech and Braille.
|
Mozilla renders tables visually (on computer screens and printers), so the 
SUMMARY attribute does not apply.

Therefore we should not display SUMMARY as a tooltip for the TABLE element, just 
as we do not display ALT as a tooltip for the IMG element.
The fix is trivial. I'll give a patch if Ian agrees.
over to htmlTables...
Assignee: ben → karnaze
Component: XP Apps: GUI Features → HTMLTables
QA Contact: sairuh → chrisd
Don't bother karnaze (especially because this is really nothing to do with the 
table code). Please assign this bug to me. If we get a consensus to change the 
spec, I'll fix the bug, otherwise I'll mark it INVALID.
Assignee: karnaze → roc+moz
Component: HTMLTables → XP Apps: GUI Features
Doing as Robert requested.  This is absolutely not a tables bug.
QA Contact: chrisd → sairuh
I disagree with mpt on this bug report.

Three reasons:

1. Supporting "summary" in _some_ way gives the web authors a reason to use that
attribute. This improves the web for non-visual browser users.

2. This attribute *is* useful to our users, if correctly used it allows tables
to be understood without reading them completely (i.e., allows the web author
to provide the reader with a summary of the table, which can be easily reached
but which is not part of the main flow of the page).

3. The spec also says "Make the table summary available to the user" (section
11.2.1 of the HTML4.01 specification).

Robert: I therefore suggest you mark this INVALID.
(Reporter)

Comment 7

18 years ago
Response to each of those points:

1.  Leaving SUMMARY as a tooltip could give Web authors a reason *not* to use
    that attribute where otherwise they would (because it is too annoying, when
    shown in Mozilla, for its benefit in other browsers to be worth it). Mozilla
    is not, and should not be, the solution to all the world's Web authoring
    problems (just some of them:-).

2.  If the table is small enough for a whole-table tooltip not to be annoying,
    then it's small enough that the summary will be of very little value to a
    visual browser -- just visually scanning the table and digesting its meaning
    will be quicker than hovering over the table, waiting for the tooltip to
    appear, and reading the tooltip.

3.  The HTML spec says that making `the table summary available to the user' is
    one of the things `user agents MAY carry out when rendering a table' (my
    emphasis). It is not something the user agent MUST (or even SHOULD) do,
    especially since SUMMARY is intended `so that people using NON-VISUAL user
    agents may better understand it' (my emphasis again). (The words `must' and
    `should' appear in various places in that section, but not in the part about
    the summary.)
mpt: Web authors have a way out although it's non-obvious. If you put elements 
in the table with a TITLE="" then no tooltip will show up over those elements. 
Not a good solution, I know.

How about a compromise: only show the SUMMARY if the hovered element is a TR, 
TD, or TABLE? So if you hover over table content there'll be no tooltip, but if 
you hover over the table border or unused space in table cells, you get the 
summary.
(Reporter)

Comment 9

18 years ago
Hiding a parent tooltip with TITLE="" is, IMO, a bug not a feature. It encourages 
cruft by enticing authors to specify TITLE="" where it is inappropriate, and may 
also (in some cases) make parent tooltips completely inaccessible.

As for SUMMARY, either show it in the whole table, or not at all. Provided that 
all the current tooltip usability bugs get fixed, I don't really care either way. 
I just want to make sure that Ian's considered this properly, since what he says 
seems to be at variance with the HTML spec.
hunh, okay. i still don't understand why it's in this particular component
(whatever), but it's not quite my realm for qa. over to chrisd for qa.
QA Contact: sairuh → chrisd
[realization: this is in xp apps since it's a tooltip, i presume... afaik, i had
thought that such bugs belong to xp toolkit/widgets. bugzilla fun.]
sorry about the noise... i'm handing the qa contact-ship to jrgm, the xp toolkit
qa'er.
QA Contact: chrisd → jrgm

Comment 13

18 years ago
I agree.  Look at http://www.w3.org.  The table summary there says "Layout 
table: The first cell contains the body of the page, the second a navigation 
bar"  Not very useful for visual users (although there might be better uses for 
it).  And it makes the page quite annoying.
Ok, I concede to the arguments presented above. Lets move "summary" out of the
tooltip code.
Whiteboard: (py8ieh:update spec)
Created attachment 11707 [details] [diff] [review]
Patch to remove TABLE SUMMARY tooltip
I think I'll check this in after nsbeta2 branch. This is not high priority.
Status: NEW → ASSIGNED

Comment 17

18 years ago
Unless you want to go triage all of the bugs we'll get on this when NS6PR2 goes 
to market and people visit bugzilla I (try to) respectfully request that you do 
this before we branch.
Keywords: nsbeta2
OK. Ben, can you review/approve? Brendan, can you give mozilla.org approval?

This only changes the Javascript code for tooltip construction, should be low 
risk.

Comment 20

18 years ago
Putting on [nsbeta2-] radar.  But this bug could be fixed by the net community 
and checked in via approval from brendan or waterson. 
  
Whiteboard: (py8ieh:update spec) → [nsbeta2-] (py8ieh:update spec)
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 24

18 years ago
*** Bug 49826 has been marked as a duplicate of this bug. ***

Comment 25

18 years ago
verified fixed.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.