Moving tab from one window to another results in replaced tab and stuck blank tab

RESOLVED DUPLICATE of bug 456002

Status

()

--
major
RESOLVED DUPLICATE of bug 456002
10 years ago
9 years ago

People

(Reporter: fehe, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080926033937 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080926033937 Firefox/2.0.0.11

My summary probably doesn't make much sense, but here goes:

If you have two windows open and only one tab per window, moving the tab of one window to the tabbar of the other window results in the tab of the target window being replaced with the tab that was moved.  In addition, a blank tab, that cannot be closed, also gets opened.

This is a regression -- likely as a result of underlying tab discover work.

Works: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080917034815

Broken: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080918073230

Reproducible: Always

Steps to Reproduce:
1. Create a new profile
2. Launch Firefox and open a new window
3. Make sure you have only one tab in each window.
4. Move the tab from one window to the tabbar of the other window
5. Notice that the tab of the target window gets replaced (this should not be) and where the tab that was moved should have been is now occupied by an "(Untitled)" tab that get added.
6. Try an close the "(Untitled)" tab.  You cannot.



Expected Results:  
One window with two tabs.
(Reporter)

Updated

10 years ago
Component: General → Tabbed Browser
Keywords: regression
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456002
QA Contact: general → tabbed.browser
You need to log in before you can comment on or make changes to this bug.