Pressing enter in address bar triggers "ASSERT: *** Search: _installLocation: engine has no file!" instead of loading URL

RESOLVED DUPLICATE of bug 427028

Status

()

Firefox
Address Bar
--
critical
RESOLVED DUPLICATE of bug 427028
10 years ago
9 years ago

People

(Reporter: Everton Fernando Patitucci da Silva, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

This bug is related to bug #427028. It's the same symptoms but with a different platform (in #427028 it's Macintosh).

Whenever I type enter in the address bar it triggers the following error message:
ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],alias)
5:()
6:SRCH_SVC_getEngineByAlias(www.google.com)
7:getEngineByAlias(www.google.com)
8:getShortcutOrURI(www.google.com,[object Object])
9:(www.google.com,[object Object])
10:(www.google.com,[object Object])
11:canonizeUrl([object KeyboardEvent],[object Object])
12:handleURLBarCommand([object KeyboardEvent])
13:anonymous(textentered,[object KeyboardEvent])
14:fireEvent(textentered,[object KeyboardEvent])
15:onTextEntered()
16:handleEnter(false)
17:onKeyPress([object KeyboardEvent])
18:onxblkeypress([object KeyboardEvent])

then if I press "OK" it'll show once again the following error message:
ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],alias)
5:()
6:SRCH_SVC_getEngineByAlias(www.google.com)
7:getEngineByAlias(www.google.com)
8:getShortcutOrURI(www.google.com,[object Object])
9:(www.google.com,[object Object])
10:(www.google.com,[object Object])
11:canonizeUrl([object KeyboardEvent],[object Object])
12:handleURLBarCommand([object KeyboardEvent])
13:anonymous(textentered,[object KeyboardEvent])
14:fireEvent(textentered,[object KeyboardEvent])
15:onTextEntered()
16:handleEnter(false)
17:onKeyPress([object KeyboardEvent])
18:onxblkeypress([object KeyboardEvent])


I know this is the same bug as in #427028, but when I noticed it was a different platform I thought it would be better to report it under a different thread. If that's bad practice please forgive me and I'll continue reporting it under #427028.

But I've got some content to add... if I type CTRL-N (open new window) it'll display an error message different than the previous one:

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],hidden)
5:()
6:()
7:currentEngine()
8:get_currentEngine()
9:updateDisplay()
10:init()
11:([object XULElement],13)

and another thing, shortcuts like CTRL-F to search something aren't working, no error message is displayed but it doesn't work (even if I try to open the search widget using the menu "Edit" -> "Find", no error message but no expected default behavior).

Whenever you click "OK" on the error message the browser proceeds as it should, it will try to reach the address you entered, the only exception is to the "Find" functionality, that doesn't show up again.

Reproducible: Always

Steps to Reproduce:
1.1.Open a new tab (CTRL-T)
1.2.Click on the address bar
1.3.Type something and press Enter

2.1.Open a new window (CTRL-N)

3.1.1.Click in the "Find" option under "Edit" menu
3.1.2.Type CTRL-F (shortcut for "Find")
Actual Results:  
1.The error message described previously shows up.

2.The second error message described previously shows up.

3.Find widget doesn't show up, but no error message appears.

Expected Results:  
1. No error message should be displayed.

2. No error message should be displayed.

3.Find widget should appear allowing the user to search for something.

Addons installed:
Delicious Bookmarks
User Agent Switcher
Which version of Delicious?  Have you tried to upgrade/disable it?
(Reporter)

Comment 2

10 years ago
Actually, I believe this is related to using a firefox client while a firefox upgrade has been triggered.

After reporting the bug, I closed the browser and later I opened it again and I noticed the feedback telling me firefox was upgraded to the latest version.

Then I remembered that while I was browsing I had firefox upgraded.
After that feedback about it being upgraded I haven't got into this bug again. 

I hope it helps and if there's still any doubt about the bug, don't hesitate to ask me... I'll help providing any info required.
Version: unspecified → 3.0 Branch

Comment 3

10 years ago
Confirming on Ubuntu 8.10 Ibex.

It's a fresh install, but I have a home directory from 8.04 with the following add-ons: 4chan, Adblock, Downthemall, Firefox Universal Uploader, TabMIx Plus, Ubuntu FIrefox Modifications, Firebug (disabled on this page).

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],alias)
5:()
6:SRCH_SVC_getEngineByAlias(http://www.twitter.com/)
7:getEngineByAlias(http://www.twitter.com/)
8:getShortcutOrURI(http://www.twitter.com/,[object Object])
9:canonizeUrl([object KeyboardEvent],[object Object])
10:handleURLBarCommand([object KeyboardEvent])
11:anonymous(textentered,[object KeyboardEvent])
12:fireEvent(textentered,[object KeyboardEvent])
13:onTextEntered()
14:handleEnter(false)
15:onKeyPress([object KeyboardEvent])
16:onxblkeypress([object KeyboardEvent])

This also happens when trying to do a Google search using the Ctrl + K search toolbar:

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],hidden)
5:()
6:()
7:currentEngine()
8:get_currentEngine()
9:TMP_SearchLoadURL(report a firefox bug,[object KeyboardEvent],true)
10:handleSearchCommand([object KeyboardEvent])
11:onTextEntered()
12:handleEnter(false)
13:onKeyPress([object KeyboardEvent])
14:onxblkeypress([object KeyboardEvent])

Comment 4

9 years ago
Platform really shouldnt matter since it is all related to not restarting browser

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427028
You need to log in before you can comment on or make changes to this bug.