SVG Fe* Filters regressed on Mac OS X / PowerPC

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: lars.sonchocky-helldorf, Unassigned)

Tracking

({regression, testcase})

Trunk
PowerPC
Mac OS X
regression, testcase
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080927020752 Minefield/3.1b1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080927020752 Minefield/3.1b1pre

the following SVG Fe* filters are broken on Mac OS X PowerPC as of Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080927020752 Minefield/3.1b1pre but did work in Firefox 3 before:

http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-conv-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-diffuse-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-displace-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-light-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-morph-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-specular-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-turb-01-f.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-color-01-b.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-composite-02-b.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-comptran-01-b.html
http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-gauss-01-b.html

Reproducible: Always

Steps to Reproduce:
1. just check the URLs above and compare the results with the PNG rendering next to it
Actual Results:  
Mostly distorted colors, look oversaturated

Expected Results:  
those should look like the PNG renderings (and did in FireFox 3)

Please click through the SVG tests at http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-index.html once you've touched some SVG code, it takes only five minutes to complete
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
Created attachment 341016 [details]
Screen shot of problem

I see the problem in today's Minefield/Firefox nightly
(2008-09-29-02-mozilla-central) on OS X 10.4.11 PPC, but not on OS X
10.4.11 Intel.

The problem doesn't start with the 2008-09-27 Minefield nightly -- I
also see it with the 2008-09-09 nightly.  I haven't yet had the time
to find a more precise regression range.

The problem is quite severe -- take a look at my screen shot.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Chris:  Another PPC-specific SVG problem on OS X (in addition to bug 452698).
> Chris:  Another PPC-specific SVG problem on OS X (in addition to bug 452698).

Oops, sorry.  Bug 452698 _isn't_ an SVG bug.

Still, though, do you have any insights into this?
Regression range:

2008-09-01-02-mozilla-central   No bug
2008-09-02-04-mozilla-central   Bug

Here are the changesets that were landed in that span of time.  But I
can't figure out which one caused/triggered this bug.

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=Sep+01+2008+00%3A00%3A00&enddate=Sep+02+2008+07%3A42%3A00
Flags: wanted1.9.1?
(Reporter)

Comment 5

10 years ago
Since this bug occurs only on PowerPC and NOT ON Intel Macs and from the way what the ligther parts of the filtered images look like (esp: http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-conv-01-f.html - strangely clipped) I strongly suppose that this is an endianness issue: PowerPC is mostly (and in case of Mac OS X) operated in Big-endian mode whereas x86 employs Little-endian. So if somebody assumed a certain byte order somewhere (e.g. writes endian dependent code) such stuff can happen. Since most programmers write code just for x86 on a daily basis they might not be aware of the issue.
Flags: wanted1.9.1? → blocking1.9.1+
I don't have my Mac yet, and it will take some time to get to grips with it once I do, so I probably can't do a lot with this just yet.
Keywords: regression, testcase
Of the changesets in the regression range given in comment 4 there is nothing that jumps out at me. If I had to guess, I'd be most suspicious of the NSPR update.

http://hg.mozilla.org/mozilla-central/rev/a9ce01b87b4c
Can someone with a Mac machine try the following Try Server build and report whether it has the bug or not please?

https://build.mozilla.org/tryserver-builds/2008-12-16_04:39-jwatt@jwatt.org-svg-filter-mac-regression/jwatt@jwatt.org-svg-filter-mac-regression-firefox-try-mac.dmg

Comment 9

10 years ago
Looked through the tests on a MacIntel with 10.5.6, and I could not see the problem. I believe tracy is looking at the problem using a PPC machine.
using given Try Server build on PPC Mac: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2a1pre) Gecko/20081216 Minefield/3.2a1pre

the given test cases looked fine except the composite one: http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-composite-02-b.html  none of the sample items are rendered; all svg samples are blank.
Actually, that same test does not work for me on the MacIntel machine.
Full-filters-composite has never worked on any architecture as it uses SVG features that are not implemented in mozilla yet.

Comment 14

10 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20081216 Minefield/3.2a1pre

I'm using the normal nightly (not a tryserver build), but filters are working for me again.
If this works on Mac PPC without jwatt's patch then we should just close this as WFM shouldn't we?
I don't have a patch for this bug.

We can close this I guess, but I'd still quite like to know what caused this and which change fixed it. I.e. I'd still be interested in Tracy testing the second try server build and Alex (or someone else) trying recent nightly builds to see when exactly filters started working again, assuming they are willing.
I'll take at look at that one later this evening or tomorrow morning. I'm taking a day of PTO to knock out my Christmas shopping today.  :-)

Comment 18

10 years ago
20081212 nightly has broken rendering, 20081213 has normal rendering.

Revision ID's are 8ff9c509ca74 and ad710c32b0e9.
Could be bug 455314 or bug 448243
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.