Changing border-width by disabling document.styleSheets[x] has no effect

RESOLVED DUPLICATE of bug 258377

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 258377
9 years ago
9 years ago

People

(Reporter: Michael Dayah, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Win64; x64; .NET CLR 2.0.50727; SLCC1)
Build Identifier: Gecko/20080927-033433 and 2008091620

If a first style sheet contains one border-width and a second style sheet contains a different one, disabling the second style sheet will not revert border-width back to the value in the first.

Reproducible: Always

Steps to Reproduce:
1. Visit textcase
2. Click "click me"
Actual Results:  
Nothing, border-width does not change.

Expected Results:  
Border-width should change.
(Reporter)

Comment 1

9 years ago
Created attachment 340816 [details]
JavaScript demo of border-width change failing
Confirmed, tested on Windows XP this works in IE 6, Google Chrome, but not in Firefox and latest Opera.
(Reporter)

Updated

9 years ago
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 3

9 years ago
The table is able to correct itself if appendChild is used to insert another cell.
Looks like yet another border-collapse dynamic update bug.  Pretty sure we have this already on file...
Component: DOM: CSS Object Model → Layout: Tables
QA Contact: general → layout.tables
Whiteboard: DUPEME
Version: 1.9.0 Branch → Trunk

Comment 5

9 years ago
how about bug 258377

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 258377
You need to log in before you can comment on or make changes to this bug.