[ru] Update for Russian spellchecking dictionary (makes "YO" letter optional)

RESOLVED FIXED

Status

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: unghost, Assigned: unghost)

Tracking

({fixed1.9.0.4})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

11 years ago
Posted patch Patch (obsolete) — Splinter Review
This is update for Russian spellchecking dictionary, that makes "YO" letter optional, as it should be.
Assignee

Updated

11 years ago
Summary: [ru] Update Russian spellchecking dictionary → [ru] Update for Russian spellchecking dictionary (makes "YO" letter optional)
Assignee

Comment 1

11 years ago
Posted patch Patch v.2 (obsolete) — Splinter Review
Attachment #340826 - Attachment is obsolete: true
Assignee

Updated

11 years ago
Attachment #340983 - Flags: approval1.9.0.4?
Assignee

Comment 2

11 years ago
Posted patch Patch v.3Splinter Review
Attachment #340983 - Attachment is obsolete: true
Attachment #342098 - Flags: approval1.9.0.4?
Attachment #340983 - Flags: approval1.9.0.4?

Updated

11 years ago
Attachment #342098 - Flags: approval1.9.0.4? → approval1.9.0.4+

Comment 3

11 years ago
Comment on attachment 342098 [details] [diff] [review]
Patch v.3

a=me for 3.0.4, please land with a check-in comment referencing this bug and my approval, and use the fixed1.9.0.4 and verified1.9.0.4 keywords to track landing and testing.
Assignee

Comment 4

11 years ago
Checking in extensions/spellcheck/hunspell/ru.dic;
/l10n/l10n/ru/extensions/spellcheck/hunspell/ru.dic,v  <--  ru.dic
new revision: 1.4; previous revision: 1.3
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.9.0.4
Resolution: --- → FIXED

Comment 5

11 years ago
There are no consensus on whether to use YO as optional or as normative one. Modern tendency is to make it normative, however it is not yet fixed as a norm.
I'd prefer my browser to check if YO is forgotten and tell me about errors like this. This is especially important for sites like Russian Wikipedia, where usage of YO is the rule. 

I think the bugfix made is to be rolled back or at least people are to have choice on how to tune their browsers.
Assignee

Comment 6

11 years ago
(In reply to comment #5)
> There are no consensus on whether to use YO as optional or as normative one.
> Modern tendency is to make it normative, however it is not yet fixed as a norm.
This is not true, see http://ru.wikipedia.org/wiki/Ё_%28кириллица%29#.D0.95_.D0.B8_.D0.81
According to rules, letter YO is optional and it's permitted to use E instead YO (with few exceptions).
Regarding consensus - I'm providing support on Russian Mozilla forum and most users are very glad that YO letter was made optional. Common consensus is that dictionary shouldn't dictate to use YO letter.

> I think the bugfix made is to be rolled back or at least people are to have
> choice on how to tune their browsers.
You can install "YO mandatory" spellchecking dictionary - it's available for download from http://ftp.mozilla-russia.org/dictionaries/russian_spellchecking_dictionary_with_yo-0.2.1-fx+tb+sm.xpi

Comment 7

11 years ago
To see what I mean under wiki rules look at: http://ru.wikipedia.org/wiki/%D0%92%D0%B8%D0%BA%D0%B8%D0%BF%D0%B5%D0%B4%D0%B8%D1%8F:%D0%81

I meant internal wikipedia rules, not what article says about the current status.

I am glad to see "YO mandatory" dictionary, however, the default one tends to push an obsolet point caused by historical situation with typewriters. I am not sure why we have to follow this rule now especially with electronic devices.

Comment 8

11 years ago
Mashiah, I don't understand your point. 
Firefox is not about russian language reform, Firefox is about russian language support.
"Yo" usage is not required by russian language norm, so omitting of "Yo" must not be treated as mistake.
I want to say more: Official russian language rules state that "Yo" MUST be written as "E" except in some explicitly stated cases (disambig, rarely words, etc). Yeah, this rule can be ignored by author or editor discretion, but this is rule.
Writing without "Yo" is a norm, and writing with "Yo" is a option.

If you want to reform russian language, please contact approp. authorities (Institute  of Russian Language of Russian Science Academy) and stop spamming firefox bugs.

>Modern tendency is to make it normative
This is not correct. There is no such tendency in russian language.

>I am not sure why we have to follow this rule
I am not sure why we keep writing "парашют" (parash'ut) while keep talking "парашут" (parashut). But this is rules of russian language, I like to follow rules of my language. I don't want my correct spelling (without "Yo") has been marked as mistake, because skipping "Yo" is not a mistake.

If you or some another moron thinks that Russian language rules are wrong, so develop and use appropriate extension. Mainstream Firefox should follow mainstream russian language.

P.S. Sorry for my English.

Comment 9

11 years ago
Thank you for your explanation. Now your point looks well-stated, and if I understood it correctly it means we follow the laws.

I just want to clarify my point here in order to make it more reasonable than it might look from your answer. Especially, for the note on the modern tendency.

I've provided the example of this tendency in my previous post and shown that internal wikipedia rules for articles creation do contradict to the "mainstream russian language" you refer to.

Anyway, you've given the link to the alternative dictionary, so I think you right and I will now stop "spamming" here.
You need to log in before you can comment on or make changes to this bug.