Closed Bug 4576 Opened 21 years ago Closed 20 years ago

RHS of borders chopped off in nested table situations

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cmaximus, Assigned: karnaze)

References

()

Details

(Whiteboard: [testcase] bloviate@yahoo.com)

Attachments

(2 files)

This bug was created based on investigation of bug 2572.

The bug is in Apprunner with the 1999040608 build on NT. *other platforms have not been checked due to current build
instability*

to reproduce:
Load www.nasa.gov and watch closely as it loads.
The page loads perfectly and then relaysout incorrectly.

The RHS of the table border of the top-right table ('today@nasa.gov') is chopped off.
The four images/links under 'Cool NASA Websites' first laysout four-in-a-row but then it relays out to 3 and 1 in the next row
because the table ends too early.
Summary: RHS of tables chopped off/closed out
d'oh forgot the summary...
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
I can no longer repro this bug with 1999040608 or 1999040718...marking WFM
Status: RESOLVED → VERIFIED
Verified WORKSFORME.
Status: VERIFIED → REOPENED
this is wierd. i just looked with MacOS, Linux, and WinNT all with the 1999052108 builds and this bug shows up, exactly the way it
was previously described. Chris, you wanna double-check and clear the WFM if it turns out I'm not crazy?
Resolution: WORKSFORME → ---
Tested using 6/3 Apprunner on Win 95, Win NT, Win 98, Mac8.5 and Linux. Bug
exists across platform (table cut off). Clearing WORKSFORME resolution.
Reproducible with the MICROSOFT WINDOWS 98 Apprunner build of 1999062508 as
described originally by claudius@netscape.com at
http://www.reston.com/nasa/watch.html (see entire left-hand column and the
yellow length labelled "HOT TOPICS" most especially).
Whiteboard: [MAKINGTEST] bloviate@yahoo.com
Whiteboard: [MAKINGTEST] bloviate@yahoo.com → [testcase] bloviate@yahoo.com
*** Bug 9394 has been marked as a duplicate of this bug. ***
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → DUPLICATE
Consolidating table/image resizing incorrectly bugs....

*** This bug has been marked as a duplicate of 2904 ***
Status: RESOLVED → REOPENED
Reopening (sorry!)
Resolution: DUPLICATE → ---
Summary: RHS of tables chopped off/closed out → RHS of borders chopped off in nested table situations
All that is needed to reproduce any of these bugs is any table that meets the
following criteria:

- There must be another table nested within one of the cells. The width of this
table doesn't matter.

- There must be a block level element (a table or div) The width of the
contents of this cell is not used correctly. The *right border* of block-level
element is not taken into account when calculating the width of the parent cell.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Fixed with 7/28 changes. Attachment #2 [details] [diff] is bug 2904.
Status: RESOLVED → VERIFIED
Using 8/5 Apprunner, verified bug fixed on www.nasa.gov page. The issue with
right borders being cut off as demonstrated by 7/23 attachment is written up in
bug #2904 as indicated by Karnaze.
You need to log in before you can comment on or make changes to this bug.