Firefox SHOULD support the SOCKS5 USERNAME/PASSWORD authentication method/Firefox displays no error if the SOCKS5 methods listed are not acceptable

RESOLVED DUPLICATE of bug 122752

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 122752
9 years ago
9 years ago

People

(Reporter: HM2K, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

The SOCKS5 specification (RFC 1928) says the following:

   Compliant implementations MUST support GSSAPI and SHOULD support
   USERNAME/PASSWORD authentication methods.

Yet firefox has no basic support for the SOCKS5 username/password auth method, as you would expect.

This auth method is a very simple concept to impliment as per RFC 1929.

The SOCKS5 specification (RFC 1928) says the following:

   If the selected METHOD is X'FF', none of the methods listed by the
   client are acceptable, and the client MUST close the connection.

If this is the case, firefox displays a blank page, instead of an error as you would expect.

Having no error makes debugging far more difficult that is required.

This causes users to produce the "not working" statement, instead of reporting an error.

Reproducible: Always

Steps to Reproduce:
1. Use a SOCKS5 server that uses USERNAME/PASSWORD authentication method.
2. Try and make it work with firefox.
3. ???
4. Profit
Actual Results:  
There's nowhere to put the username and password/a blank page is displayed.

Expected Results:  
Somewhere to put the username and password/display an error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 122752
You need to log in before you can comment on or make changes to this bug.