There is a lack of detail in the help section for SOCKS/proxies

VERIFIED WONTFIX

Status

support.mozilla.org
Knowledge Base Articles
--
minor
VERIFIED WONTFIX
9 years ago
9 years ago

People

(Reporter: HM2K, Assigned: benc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

The help section does not explain the various options.

It does not explain the difference between a HTTP Proxy and a SOCKS Host, nor anything inbetween.

It does not tell you what protocols, RFCs and methods are supported.

It does not offer any examples, or suggestions on how it should be used, and how it is expected to work.

Does the HTTP Proxy only route HTTP traffic, if so what does the SOCKS host do? Do we assume that does HTTP as well, or all? If so, what does the FTP proxy do? HTTP only, or both, all, or perhaps even none?

There is no way of knowing how "Use this proxy server for all protocols" is meant to work.

There is no mention of which auth methods are used.

Is it assumed that the user is meant to automatically know? If so what is this logic based on?

Do I need to be a developer to use a proxy?

One thing is for sure, the help isn't going to tell me...

Reproducible: Always

Steps to Reproduce:
1. Go to help from the connectivity tab.
Actual Results:  
Poor help

Expected Results:  
Good help
The http proxy only does http of course while ftp does ftp only.
Socks a complete different type of proxy and can handle all kind of protocols.
You can not expect that there will be a a full help with RFC number etc because that doesn't matter as User.
You as User either have to use a proxy and you get the instructions which host/port you have to use as proxy. If you yourself install a proxy server then you should which type of proxy you must use.
If you want to know what a socks proxy is then use for example wikipedia
Component: General → Knowledge Base Articles
Product: Firefox → support.mozilla.com
QA Contact: general → kb-articles
(Reporter)

Comment 2

9 years ago
I'm not expecting developer style help in the user help file, I'm expecting any help at all.

In the initial notes I said poor help, I should have said no help, my mistake.

Am I right in saying that you are suggesting that proxies aren't used by users, and are only to be used by IT professionals? Are you saying that users do not need to know what the proxy settings mean and are expected to follow instruction sets without questioning?

I don't need to know about SOCKS, it was a hypothetical question. Users do need to know about SOCKS and proxies within the context of Firefox, but they don't need to know how it works.

Wikipedia does not explain the use of the SOCKS proxy within the context of Firefox. More to the point, I am an editor of that article, and I'm telling you, the firefox help on this is non-existent.
I think http://support.mozilla.com/en-US/kb/Options+window#Network_tab covers it fairly well for the basic user - that is to say if the user has a proxy to use, this documentation is enough to help them use it. I think the first paragraph gives a good explanation of what proxies are and who would use them.

However, the UI lists different types of proxies that can be manually configued and so I don't think it would be wrong for the documentation to list the types of proxies supported.
(Reporter)

Comment 4

9 years ago
I can't find the word "SOCKS" on that page, clearly even the basics aren't even mentioned. Users are confused.
a) The basics are covered. The article says this:

    *  Manual proxy configuration: Choose this if you have a list of one or more proxy servers. 

Ask your system administrator for the configuration information. Each proxy requires a hostname and a port number. 

Users who have a proxy will be able to figure out the rest giving their information. If you have a SOCKS proxy you'll know where to put the information. If you don't know what a SOCKS proxy is, you probably don't have one and you don't need to know what one is to continue using Firefox correctly.

Where are you seeing confused users? If you can link to that it'll be easier for us to determine what changes are warranted. Though I already did say that I think the article could stand to list what types of proxies Firefox supports (this would be helpful for users who want to use a proxy but haven't checked the options panel yet to see what is supported).
(Reporter)

Comment 6

9 years ago
Define the difference between a HTTP proxy and a SOCKS proxy, and how a user is supposed to know the difference.

After all, a HTTP proxy is for http traffic, and a SOCKS proxy can handle HTTP traffic, but a HTTP proxy is not always a SOCKS proxy, and a SOCKS proxy is not always a HTTP proxy...

Why does Firefox let you "use this proxy for all protocols" without even explaining the difference between them -- this simply won't work, unless the proxy supports all the protocols that firefox allows to be "proxified".

Why would you use a HTTP proxy for the FTP protocol, or even the SOCKS protocol? It doesn't even make any sense. The help does not even define it within the context of itself, how is anyone supposed to know for sure without reading the development notes or the code itself?

Unless users are just expected to guess? Perhaps that's it.
You can not expect that we explain what is socks proxy is or what the difference between a socks a http proxy is or do you also expect for File/send link that we explain what a link is ?

Either you get information from your admins which proxy you should use, you know it yourself or you have to use google.

>Why does Firefox let you "use this proxy for all protocols" without even
>explaining the difference between them 

Is is self explaining except that it will not use socks but you can either enter the information in http, ftp, https and if you have the same host/port you can use "use this proxy for all protocols".
(Reporter)

Comment 8

9 years ago
I'm glad you agree that it's not explained as well as it could be.

You're right, more should be done to explain the interface, or the interface could be changed to make it more obvious to the user as to exactly what they are supposed to be googling/asking their admin for.

I find that Mozilla seem to model this section on Internet Explorer's. There's a reason why proxy plugin interfaces (such as foxyproxy) aren't like Firefox's.

Perhaps the documentation isn't the main problem, perhaps the interface is. However what I do know is that either way better documentation on this should be added to assist this section better.
(In reply to comment #6)

> Why does Firefox let you "use this proxy for all protocols" without even
> explaining the difference between them 

I believe this section of the article explains this fairly clearly:

"Ask your system administrator for the configuration information. Each proxy requires a hostname and a port number.

          o If the same proxy name and port number are used for all proxies, check Use this proxy server for all protocols."
Ben, what do you think about this?

mozilla@hm2k.org, what text would you recommend for that section?

Comment 11

9 years ago
hi. This is Girish here.

I am going to create an article based on queries or expected result so said (Ref. Bug Discription)

I am in favor of
Flags: blocking-firefox3.1?

Comment 12

9 years ago
I am in favor of HM2K, really it should be like that way. Regards.
(Assignee)

Comment 13

9 years ago
HM2K: that's a bug. I'll make a longer comment later today to explain.
Assignee: nobody → benc
(Assignee)

Comment 14

9 years ago
So, I re-wrote most of the online/FF3 help, with the assumption that we'd have more extensive docs for a systems administrator. 

In the past, the entire client (browser) -> server (proxy) architecture was sort of pre-existing. The two browser vendors were also the proxy vendors, and they had already sold the proxy to the customer. Everyone else with a proxy had already understood the environment, and opted out to a 3rd party proxy server.

Fast forward to today, and lots of people have the browser, and they stare at the screen wondering: what is this?

So, one of my goals was to write a system-admin's version of the docs, that answered all the questions you have.

Also, I was going to update and roll up the content from here:

http://packetgram.com/pktg/proxy/protocols.html

I had also contemplated getting wikipedia access, because article on proxy servers lists lots of terms, but doesn't organize the explaination so that a real world person can understand what is going on.
(Assignee)

Comment 15

9 years ago
Okay, so to answer a couple questions:

HTTP Proxy and the other non-SOCKS proxies are all the same. They use "HTTP" proxy, which is really a proxy that accepts URL requests of HTTP. The HTTP could be unencrypted (http:) or encrypted (https:), mozilla probably only supports unencrypted at this point.

SOCKS is a completely different application-level protocol. It emulates most of the basic network functions available in a socket library.

[So, yes, if you are wondering, the "all" checkbox making HTTP and SOCKS proxy the same, that is wrong (bug 449251).

There is such a thing as an FTP proxy that is an FTP-only proxy. They pre-date Navigator's proxy support, and the meaning of the term got overwritten, due to Netscape's mis-naming of its much more popular product.

I was in the process of documenting the current FF3 UI design in mdc, but I had also wanted to create a sys-admin document. The original agreement was that this was less suitable for SMO and more welcome for MDC. I'll let everyone discuss that and decide.

A couple other things:

I've always wanted the product experience to be more seamless. Maybe we could post something like a "feature certification suite" for vendors. If they pass the suite, they could say they work w/ version blah. And it would also help them write and update their vendor side documentation.

Another possibility is that contributors could provide glue docs, like: if this is your proxy server, here's what your config could/should look like in FF3.
(In reply to comment #15)
> Okay, so to answer a couple questions:
> 
> HTTP Proxy and the other non-SOCKS proxies are all the same. They use "HTTP"
> proxy, which is really a proxy that accepts URL requests of HTTP. The HTTP
> could be unencrypted (http:) or encrypted (https:), mozilla probably only
> supports unencrypted at this point.
> 
> SOCKS is a completely different application-level protocol. It emulates most of
> the basic network functions available in a socket library.

This kind of information would definitely be useful for administrators, but it's not something end-users need to know in order to use Firefox. As the documentation says: "Ask your system administrator for the configuration information."

> I was in the process of documenting the current FF3 UI design in mdc, but I had
> also wanted to create a sys-admin document. The original agreement was that
> this was less suitable for S[U]MO and more welcome for MDC.

...which is still true. :) Explaining in detail what SOCKS/proxies are would be like explaining what RSS/Atom feeds are. We don't do that; instead, we explain how to use Live Bookmarks (http://support.mozilla.com/en-US/kb/Live+Bookmarks). The same policy applies here: we explain what the user needs to know, now how the underlying technology works. That's what MDC is for.

To clarify, I think documenting this in detail is a great idea, but the content is not suitable on SUMO; it should be on MDC, or possibly somewhere on the Mozilla Wiki. Moreover, a discussion about making the product experience more seamless is more suitable on mozilla.dev.apps.firefox.

The bug as it's defined now is a WONTFIX, because SUMO targets end-users.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
v
Status: RESOLVED → VERIFIED

Updated

9 years ago
Flags: blocking-firefox3.1?
You need to log in before you can comment on or make changes to this bug.