Closed Bug 457746 Opened 14 years ago Closed 14 years ago

mChannel can be bogusly null in XMLHttpRequest

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 390219

People

(Reporter: bzbarsky, Unassigned)

Details

We reset mChannel when we get OnStopRequest, but we aren't verifying that it's OnStopRequest for the right channel.  So in a testcase like this:

      var xhr = new XMLHttpRequest();
      xhr.open("GET", uri);
      xhr.send("");
      xhr.abort();
      xhr.open("GET", uri);
      xhr.send("");

we will null out mChannel once we get OnStopRequest for the first channel, and after that get various things wrong about the second channel....  Testcases and patch hopefully coming up soon.
Nevermind.  This was branch-only.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390219
I checked in a test for this too.
Flags: in-testsuite+
QA Contact: content
Component: Content → DOM
QA Contact: content → general
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.