"ASSERTION: didn't call Disconnect" with XMLHttpRequestUpload.onabort

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jruderman, Assigned: smaug)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 341023 [details]
testcase

Steps to reproduce:
1. Load the testcase.
2. Quit Firefox using Cmd+Q.

Result:

###!!! ASSERTION: didn't call Disconnect: '!mTarget', file /Users/jruderman/central/content/events/src/nsEventListenerManager.cpp, line 353

I think the problem is that mListenerManager is set by nsXHREventTarget, a base class for both nsXMLHttpRequestUpload and nsXMLHttpRequest, but only nsXMLHttpRequest's destructor calls Disconnect.  The least disruptive fix would be to make nsXMLHttpRequestUpload's destructor do the same, but it might make more sense to move it to mListenerManager's destructor if that doesn't cause timing issues.
(Assignee)

Comment 1

10 years ago
We want Upload's dtor to do the same thing as XHR's dtor.
(Assignee)

Comment 2

10 years ago
Created attachment 341101 [details] [diff] [review]
proposed patch
Assignee: nobody → Olli.Pettay
Status: NEW → ASSIGNED
Attachment #341101 - Flags: superreview?(jst)
Attachment #341101 - Flags: review?(jst)

Updated

10 years ago
Attachment #341101 - Flags: superreview?(jst)
Attachment #341101 - Flags: superreview+
Attachment #341101 - Flags: review?(jst)
Attachment #341101 - Flags: review+
(Reporter)

Updated

10 years ago
Flags: in-testsuite+
(Reporter)

Comment 3

10 years ago
I think Smaug forgot to mark this as FIXED.

Fix:
http://hg.mozilla.org/mozilla-central/rev/a19ab7286802

Crashtest:
http://hg.mozilla.org/mozilla-central/rev/bad67e7ea71b
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.