Use a threadpool for preload threads

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mrbkap, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Currently, we'll happily create as many threads as parsers for preloading. While this is OK, I worry about the edge case where somebody is recovering for a crash with 50 windows and 10 tabs in each window. In such a case, we'll create too many threads and possibly run out of resources. We could create a threadpool to limit the number of preload threads at any time to something reasonable like 10 or 20.
Flags: blocking1.9.1?
Not fixing this before checking in turned out to be the cause of major crashiness. The version that stuck uses a threadpool.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9.1?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.