Mailbody + attachment not shown if "This body part will be downloaded on demand."

VERIFIED DUPLICATE of bug 190905

Status

MailNews Core
Networking: IMAP
P3
normal
VERIFIED DUPLICATE of bug 190905
18 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
I have a message on my Exchange server that neither Netscape 4.73 or Mozilla can 
show.
It's because of the attachment of the mail contains this text:
"This body part will be downloaded on demand."
I can see this if I use view source with Netscape 4.73

In both Mozilla and Netscape I'm only shown the header infomation and nuthing 
else....
With Outlook Express everything works fine.

Build 20000718
(Reporter)

Comment 1

18 years ago
Created attachment 11532 [details]
mail source from view-source

Updated

18 years ago
QA Contact: lchiang → pmock
(Assignee)

Comment 2

18 years ago
Just so I'm clear, when you view the example message you posted the message pane
(outside of the headers) is blank? that sounds bad. but 4x does the same thing....
Target Milestone: --- → M18
(Reporter)

Comment 3

18 years ago
Yes, the message pane is blank.

Comment 4

18 years ago
I routinely see this with 4.x and Mozilla. I just checked M18 and still see the 
problem there (Build ID 2000101014, NT 4.0 SP5). The workaround that has always 
worked for me is to forward the message to myself. I checked a couple of 
messages that show this problem and a couple that don't, and the "This body part 
will be downloaded on demand." string is present in the former but not the 
latter.

Comment 5

18 years ago
I don't know about the "because" part. It may be related, but it's perfectly OK
to have attachments that aren't downloaded.

Comment 6

18 years ago
I suspect this has more to do with the multipart-mixed content type. Jeff, does
this make sense to you?

Comment 7

18 years ago
Not really. Is it possible to attach the mail source from Outlook Express?

Comment 8

17 years ago
adding keyword
Keywords: mail3

Comment 9

17 years ago
marking nsbeta1-
Keywords: nsbeta1-

Comment 10

17 years ago
Assign to myself.
QA Contact: pmock → fenella

Comment 11

17 years ago
To Esther..
QA Contact: fenella → esther

Updated

17 years ago
Target Milestone: M18 → ---
John, Henrik, could you possibly attach the source of that mail from some mail
program that _is_ reading it completely?

Comment 13

17 years ago
Seeing this in recently. Similar cases.
Only for attachment file larger than 1MB.

Updated

16 years ago
QA Contact: esther → trix

Comment 14

16 years ago
How is this bug going? Someone knows?

Comment 15

16 years ago
I have recieved a number of e-mails displaying the same symptoms but from a
different message source.   I will attach the message source in question.

Comment 16

16 years ago
Created attachment 100742 [details]
message source
QA Contact: trix → stephend

Comment 17

15 years ago
I see the same symptoms on mozilla 1.3a. Solaris build provided by Sun
Microsystems (downloaded from a mozilla mirror site). The message body shows
"This body part will be downloaded on demand."

No attachement pane is shown to download the (large) attachments from server. 

The message source shows complete message with inline attachement (html page in
this case).

Moving the message to local folders (not imap) shows the attachements. moving it
back brings the same problem back.

Comment 18

15 years ago
Created attachment 116076 [details]
Email source

This email does not show the body nor the attachement pane as per above
message.
(the mail addresses and server name/IP addresses have been changed)

Comment 19

15 years ago
I am seeing this in Mozilla 1.5rc2 and Thunderbird 0.3rc2. The IMAP server is
Microsoft Exchange 6 and copying the message to local folders (but not other
IMAP servers) fixes it.

The message body displays as "This body part will be downloaded on demand." And
the attachments ARE displayed correctly.
Created attachment 133687 [details]
mail src that does this in thunderbird 0.3

This is the source of a message in my IMAP inbox that exhibits this problem
when viewed in Thunderbird 0.3. The source was obtained using View Source in
Thunderbird 0.3 itself, so the message is apparently fully downloaded, just not
correctly displayed.

Comment 21

14 years ago
Also seeing this problem under with a courier IMAP server and Mozilla 1.5. Seems
to happen to some multipart/mixed messages, but certainly not all of them. View
Source always works properly on them, and they will display properly when I go
into the INBOX properties, then offline, and select "Download all."

Comment 22

14 years ago
Do you have the menu item View | Display Attachments Inline checked or not? If
it's not checked, this bug is a dup and should already be fixed in the latest
nightly Thunderbird and Mozilla builds.

Comment 23

14 years ago
Not checked.

Still occuring in 1.6 Release, so I assume the bug fix for the bug this is a
dupe for didn't make it in to that branch. I'll pull down a Thunderbird build
and check with that.

Comment 24

14 years ago
yes, I don't think this made 1.6.

Comment 25

14 years ago
OK, Thunderbird 0.5a (20040120) does not exhibit the problem, even with the 
"Display Inline" turned off.

Comment 26

14 years ago
marking wfm - it should be fixed in 1.7 as well.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 27

14 years ago
marking dup.

*** This bug has been marked as a duplicate of 190905 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core

Comment 29

13 years ago
I still see this problem in Mozilla 1.7.8
UW IMAP server.

It happens very infrequently, but it seems like it is happening more for certain
users.  I could not yet verify that this is because it happens more for mail
from certain senders (it does not look like that).
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.