AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@avgssff.dll@0x9943][@strchr | avgssff.dll@0x5546f]

RESOLVED FIXED

Status

()

defect
P2
critical
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: chofmann, Assigned: Dolske)

Tracking

({crash, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [crashkill][crashkill-thirdparty], crash signature)

pretty sharp increase in the number of crash reports (current ranked #7) around this stack trace.  Very similiar to https://bugzilla.mozilla.org/show_bug.cgi?id=436302 where we blocked older versions of roboform

0  	mozcrt19.dll  	strchr  	strchr.asm:101
1 	avgssff.dll 	avgssff.dll@0x5546f 	
2 	avgssff.dll 	avgssff.dll@0x22092 	
3 	avgssff.dll 	avgssff.dll@0x219f6 	
4 	avgssff.dll 	avgssff.dll@0x21b33 	
5 	xul.dll 	nsFactoryEntry::GetFactory 	mozilla/xpcom/components/nsComponentManager.cpp:3562
6 	xul.dll 	nsComponentManagerImpl::CreateInstance 	mozilla/xpcom/components/nsComponentManager.cpp:1666
7 	xul.dll 	xul.dll@0x7b7eff

(comment: On upgrade firefox will not restart) 

and a few with

0  	mozcrt19.dll  	strchr  	strchr.asm:101
1 	PlainOldFavorites.dll 	PlainOldFavorites.dll@0x4ebf 	
2 	PlainOldFavorites.dll 	PlainOldFavorites.dll@0x1dfb 	

(comment: crashes everytime you close it.)
OS: Mac OS X → Windows XP
FYI: I think a reporter had this problem in bug 457248
Assignee: nobody → prazak
Duplicate of this bug: 463583
Note: AVG Free's plugin still has this bug... Anyone have a contact?

Rewording title to make it more correct

Workaround is to restart in safe mode, disable AVG SafeSearch, then quit and restart normally.
Summary: Firefox 3.0.3 Crash Reports in [@ strchr -- avgssff.dll & PlainOldFavorites.dll → AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@ strchr -- avgssff.dll]
Rey: Does anyone on that add-ons team have a contact here? (I don't, personally.)
#44 crash for Firefox 3.5.2.
Keywords: crash, topcrash
Kev, do you have an AVG SafeSearch contact?

Anyone know whether this still happens with the current version of AVG SafeSearch?  If not, blocklisting the older versions might be appropriate.
Summary: AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@ strchr -- avgssff.dll] → AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@ strchr -- avgssff.dll] & [@avgssff.dll@0x9943 ]
Whiteboard: [crashkill]
Depends on: 523876
Added bug 523876 specifically for vendor outreach to AVG.
Priority: -- → P2
Severity: normal → critical
Whiteboard: [crashkill] → [crashkill][crashkill-thirdparty]
Looking at that bug it appears to be related to a strchr problem  
that was showing up in avgssff.dll version 8.0.0.148 and prior.   
This is over a year old and I would say we do not have a problem  
with you blocking any AVG SafeSearch that has a version of "8.0".   
Can you provide any more details on what the current crashes are.   
Are they still from the "8.0" or are you seeing "8.5" or "9.0"?
It looks like this problem has mostly gone away...

In the past 2 weeks on all FF versions, there are only 79 signatures matching "strchr | avgssff.dll@0x5546f". [It's possible there are more -- the same query shows an additional 2427 crashes at just "strchr"... But skimming though a few of those indicates that (1) the stacks are broken, so I can't see what called strchr and (2) avgssff.dll isn't present in the modules list anyway.]

For the [@strchr | avgssff.dll@0x5546f] crashes, the module list indicates the majority are avgssff.dll version 8.0.0.148 (with a handful of other 8.0.0.* versions).

So, the blocklisting we're doing in bug 519340 should take care of this too.
Assignee: prazak → dolske
Summary: AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@ strchr -- avgssff.dll] & [@avgssff.dll@0x9943 ] → AVG SafeSearch crash: Firefox 3.0.x Crash Reports in [@avgssff.dll@0x9943][@strchr | avgssff.dll@0x5546f]
Depends on: 527135
Calling this fixed, any further work would be in new bugs at this point.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Crash Signature: [@avgssff.dll@0x9943] [@strchr | avgssff.dll@0x5546f]
You need to log in before you can comment on or make changes to this bug.