Command-Q quits Firefox regardless of what the "Quit Firefox" keyboard shortcut is set to

RESOLVED DUPLICATE of bug 938303

Status

()

defect
RESOLVED DUPLICATE of bug 938303
11 years ago
5 years ago

People

(Reporter: keithr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

I want to remap the "Quit Firefox" menu item from Command-Q to something else, because I occasionally fat-finger Command-W and end up closing the whole browser.  I can remap the keyboard shortcut using the Keyboard & Mouse settings in System Preferences, and the new shortcut works for quitting Firefox (although not every possible binding - it seems to require that Command be one of the modifiers).  But Command-Q *ALSO* quits Firefox, defeating the purpose of changing the keyboard shortcut (for me, anyway).  The modified shortcut is what appears next to "Quit Firefox" in the menu, but Command-Q still works.

Reproducible: Always

Steps to Reproduce:
1. Using the Keyboard & Mouse pane in System Preferences, add a keyboard shortcut for the "Quit Firefox" menu item that's something other than Command-Q.
2. Start Firefox (or quit and restart if it was already running).
3. Press Command-Q.
Actual Results:  
Firefox quits.

Expected Results:  
Nothing should happen (or the error tone should sound), because command-q is no longer the keyboard shortcut for the "Quit Firefox" menu item.

I'm using the default theme.  I haven't tried any other themes.
custom keyboard shortcuts don't work yet
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
(In reply to Jo Hermans from comment #1)
> *** This bug has been marked as a duplicate of bug 429824 ***

This bug is for;
> I can remap the keyboard shortcut using the Keyboard & Mouse settings in System Preferences, 
> and the new shortcut works for quitting Firefox (although not every possible binding
> - it seems to require that Command be one of the modifiers). 
>  But Command-Q *ALSO* quits Firefox, defeating the purpose of changing the keyboard shortcut (for me, anyway). 
> The modified shortcut is what appears next to "Quit Firefox" in the menu, but Command-Q still works.
i.e.
   newly assigned shortcut to "Quit Firefox" works pretty well as expected.
   Command-Q still invokes Quit, even after successfull shortcut change.

Bug 429824 is for problem of "new short cut doesn't work".
How can this bug be dup of bug 429824?
Jo Hermans, how did you veryfy that this bug is actually dup of bug 429824?

Re-opening, with setting dependency to bug 938303 for ease of problem analysis and tracking.
Status: RESOLVED → REOPENED
Depends on: 938303
Ever confirmed: true
Resolution: DUPLICATE → ---
Problem will be fixed by bug 938303. Dupin to that bug.
Status: REOPENED → RESOLVED
Closed: 11 years ago5 years ago
No longer depends on: 938303
Resolution: --- → DUPLICATE
Duplicate of bug: 938303
You need to log in before you can comment on or make changes to this bug.