Last Comment Bug 458057 - compile error for widget/src/gtk2/nsWindow.cpp
: compile error for widget/src/gtk2/nsWindow.cpp
Status: RESOLVED FIXED
: verified1.9.1, verified1.9.2
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: PowerPC AIX
: -- normal (vote)
: mozilla1.9.3a4
Assigned To: Uli Link (:ul-mcamafia)
:
Mentors:
Depends on:
Blocks: 537588
  Show dependency treegraph
 
Reported: 2008-10-01 08:35 PDT by Uli Link (:ul-mcamafia)
Modified: 2010-04-23 06:04 PDT (History)
6 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.4-fixed
.10-fixed


Attachments
For AIX compatibilty (2.11 KB, patch)
2009-10-29 03:19 PDT, Uli Link (:ul-mcamafia)
roc: review+
Details | Diff | Splinter Review
recreated patch with hg for trunk [Checkin: Comment 10] (1.96 KB, patch)
2010-02-23 11:02 PST, Uli Link (:ul-mcamafia)
no flags Details | Diff | Splinter Review
recreated patch with hg for branch 1.9.2, context adjusted only [Checkin: Comment 13] (1.96 KB, patch)
2010-02-23 11:04 PST, Uli Link (:ul-mcamafia)
dveditz: approval1.9.2.4+
Details | Diff | Splinter Review
recreated patch with hg for branch 1.9.1, context adjusted only [Checkin: Comment 14] (1.93 KB, patch)
2010-02-23 11:30 PST, Uli Link (:ul-mcamafia)
dveditz: approval1.9.1.10+
Details | Diff | Splinter Review

Description Uli Link (:ul-mcamafia) 2008-10-01 08:35:41 PDT
User-Agent:       Mozilla/5.0 (X11; U; AIX 5.1; en-US; rv:1.8.1.17) Gecko/20080905 Firefox/2.0.0.17
Build Identifier: CVS HEAD + TRUNK

Compiling on a UNIX platform with non XFree86 X-server fails because 
#include <X11/XF86keysym.h> cannot be found and there are no XF86_XP keysymbols  defined on those platforms.
Found on both Firefox 3.0.3 and Trunk

Reproducible: Always

Steps to Reproduce:
1. Build on AIX 5.1 with GTK 2.10.3
2.
3.
Actual Results:  
compile error

Expected Results:  
successful compilation
Comment 1 Uli Link (:ul-mcamafia) 2009-10-29 01:32:24 PDT
It's easy to #ifdef around, but the proper way seems using the configure's output if XFree86/X.org X server is detected instead of
 
#if not defined (_AIX41)
...
#endif /* (_AIX41) */

around the XF86_XP... keysymbols.
Comment 2 Shailen 2009-10-29 02:54:27 PDT
In my build machine, I copied the file X11/XF86keysym.h from AIX 6 to AIX 5 under /usr/include/X11
Comment 3 Uli Link (:ul-mcamafia) 2009-10-29 03:19:28 PDT
Created attachment 409055 [details] [diff] [review]
For AIX compatibilty
Comment 4 Uli Link (:ul-mcamafia) 2009-10-29 03:24:29 PDT
Usually it's not a good idea to just copy headers from newer releases back to older.

This may result in linker errors, if the new header declares something not available in the host libs, or even worse occur at runtime.

I'm not happy with the above patch because the second hunk should be included if the machine has XFree86 not vice versa.
Else it works and is a safe shot.
Comment 5 Uli Link (:ul-mcamafia) 2009-11-27 03:34:02 PST
(In reply to comment #2)
> In my build machine, I copied the file X11/XF86keysym.h from AIX 6 to AIX 5
> under /usr/include/X11
Missing in source diff file Firefox.base.3_0_7.source.diffs as this isn't delivered neither with AIX nor compiler
Comment 6 Uli Link (:ul-mcamafia) 2010-02-23 11:02:32 PST
Created attachment 428484 [details] [diff] [review]
recreated patch with hg for trunk
[Checkin: Comment 10]
Comment 7 Uli Link (:ul-mcamafia) 2010-02-23 11:04:08 PST
Created attachment 428486 [details] [diff] [review]
recreated patch with hg for branch 1.9.2, context adjusted only
[Checkin: Comment 13]
Comment 8 Uli Link (:ul-mcamafia) 2010-02-23 11:30:21 PST
Created attachment 428492 [details] [diff] [review]
recreated patch with hg for branch 1.9.1, context adjusted only
[Checkin: Comment 14]
Comment 9 Uli Link (:ul-mcamafia) 2010-03-13 13:10:17 PST
Another superreviewer for gfx available ???
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-03-28 08:55:50 PDT
http://hg.mozilla.org/mozilla-central/rev/9e4a10b4469e
Comment 11 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-03-28 08:58:57 PDT
This is essentially NPOTB for supported platforms, so these should be easy approvals.
Comment 12 Daniel Veditz [:dveditz] 2010-03-29 10:58:33 PDT
Comment on attachment 428492 [details] [diff] [review]
recreated patch with hg for branch 1.9.1, context adjusted only
[Checkin: Comment 14]

Approved for 1.9.2.3 and 1.9.1.10, a=dveditz for release-drivers
Comment 13 Serge Gautherie (:sgautherie) 2010-03-29 16:46:12 PDT
Comment on attachment 428486 [details] [diff] [review]
recreated patch with hg for branch 1.9.2, context adjusted only
[Checkin: Comment 13]


http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1ea19a395253
Comment 14 Serge Gautherie (:sgautherie) 2010-03-29 17:24:55 PDT
Comment on attachment 428492 [details] [diff] [review]
recreated patch with hg for branch 1.9.1, context adjusted only
[Checkin: Comment 14]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/666bfd96c47f

Note You need to log in before you can comment on or make changes to this bug.