geolocation - throws NS_ERROR_NOT_AVAILABLE when no geolocation provider

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
3 months ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

Trunk
All
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

11 years ago
Posted patch patch v.1Splinter Review
if there is no geolocation provider, calls to Allow() return NS_ERROR_NOT_AVAILABLE which is passed back to js.  this shouldn't happen.
Attachment #341361 - Flags: review?(jst)
Attachment #341361 - Flags: superreview+
Attachment #341361 - Flags: review?(jst)
Attachment #341361 - Flags: review+
Hardware: PC → All
Version: unspecified → Trunk
Assignee

Comment 1

11 years ago
this has already landed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 493811
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.