Last Comment Bug 458167 - Fix bad usage of "it's" (and other misc typos) in comments
: Fix bad usage of "it's" (and other misc typos) in comments
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla13
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
http://www.stormloader.com/garyes/its...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 23:45 PDT by Daniel Holbert [:dholbert]
Modified: 2012-02-15 09:17 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
"it's" fixes patch 1: misc [landed 2008/10/01] (64.22 KB, patch)
2008-10-01 23:45 PDT, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
"it's" fixes patch 2: content [landed 2009/01/23] (20.08 KB, patch)
2009-01-22 09:11 PST, Daniel Holbert [:dholbert]
jst: review+
jst: superreview+
Details | Diff | Splinter Review
"it's" fixes patch 3: db [landed 2009/01/23] (4.86 KB, patch)
2009-01-22 09:12 PST, Daniel Holbert [:dholbert]
Pidgeot18: review+
Details | Diff | Splinter Review
"it's" fixes patch 4: docshell [landed 2009/02/05] (1.96 KB, patch)
2009-01-22 09:14 PST, Daniel Holbert [:dholbert]
benjamin: review+
Details | Diff | Splinter Review
"it's" fixes patch 5: dom [landed 2009/01/23] (5.27 KB, patch)
2009-01-22 09:14 PST, Daniel Holbert [:dholbert]
jst: review+
jst: superreview+
Details | Diff | Splinter Review
"it's" fixes patch 6: editor folder (39.47 KB, patch)
2009-01-22 09:15 PST, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
"it's" fixes patch 7: embedding [landed 2009/02/05] (13.35 KB, patch)
2009-01-22 09:15 PST, Daniel Holbert [:dholbert]
benjamin: review+
Details | Diff | Splinter Review
"it's" fixes patch 8: extensions folder (3.49 KB, patch)
2009-01-22 09:16 PST, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
"it's" fixes patch 9: gfx [mailed to cairo] (5.85 KB, patch)
2009-01-22 09:17 PST, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
"it's" fixes patch 6: editor folder (v2) [landed 2012-02-15] (34.15 KB, patch)
2012-02-08 14:42 PST, Daniel Holbert [:dholbert]
ehsan: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2008-10-01 23:45:24 PDT
Created attachment 341406 [details] [diff] [review]
"it's" fixes patch 1: misc [landed 2008/10/01]

After noticing an instance of the possessive "its" being misspelled as "it's", I was inspired to clean up these sorts of typos on a large scale.

I'm filing this bug to manage these typo-fixes -- to have a bug to mention in the checkin comments, and to have a place for people to comment in case they dispute one of the changes. :)

I'm attaching "volume 1" of fixes, which covers these subdirectories (or at least, the bits of them that get checked out with mozilla-central):
  accessible
  browser
  config
  profile
  rdf
  toolkit
  tools
  xpcom
  xpfe
Comment 1 Daniel Holbert [:dholbert] 2008-10-01 23:50:49 PDT
Just landed vol1 (attachment 341406 [details] [diff] [review]) as http://hg.mozilla.org/mozilla-central/rev/d47a01a87c6c
Comment 2 Justin Dolske [:Dolske] 2008-10-02 00:14:36 PDT
Its great you took the time to fix these!
Comment 3 Axel Hecht 2008-10-02 04:48:38 PDT
My personal opinion is that patches like this shouldn't land without module owner consent (to avoid busting existing patches), and clearly not without review. And not on a closed tree either.
Comment 4 Daniel Holbert [:dholbert] 2008-10-02 05:57:20 PDT
> and clearly not without
> review. And not on a closed tree either.

Hmm... I've been told multiple times that minor, obvious comment-only typo-fixes don't need review.

I also thought I'd been told that such changes are considered NPOTB and are OK to land even during minor closures, as long as it's cool by the sheriff.  In this particular case, sheriff was #developers, and no one in #developers objected when I asked about this.  (Also, the tree was green, and this particular closure was just "for various landings" which AFAIK had already been landed.)  Also, there had already been a number of earlier whitespace-only commits to trigger builds (e.g. changeset fff6e8b4d30f), and my commit didn't seem very different from those.

> My personal opinion is that patches like this shouldn't land without module
> owner consent (to avoid busting existing patches)

That's a fair point, regarding merge issues in outstanding patches --  I'll make sure to check with relevant module-owners / peers before landing future volumes in this family of patches. :)

(I'm also happy to back the existing patch out, if any module owner would prefer that I postpone these typo-fixes in their module until after something lands...  but otherwise, I'd lean towards leaving it, because I think we're better with the fixed comments. :))
Comment 5 neil@parkwaycc.co.uk 2008-10-03 06:12:07 PDT
Comment on attachment 341406 [details] [diff] [review]
"it's" fixes patch 1: misc [landed 2008/10/01]

>-  // that it's operation be reversable from Finish.
>+  // that its operation be reversable from Finish.
reversible ;-)
Comment 6 Daniel Holbert [:dholbert] 2009-01-22 09:11:34 PST
Created attachment 358189 [details] [diff] [review]
"it's" fixes patch 2: content [landed 2009/01/23]
Comment 7 Daniel Holbert [:dholbert] 2009-01-22 09:12:56 PST
Created attachment 358190 [details] [diff] [review]
"it's" fixes patch 3: db  [landed 2009/01/23]
Comment 8 Daniel Holbert [:dholbert] 2009-01-22 09:14:07 PST
Created attachment 358191 [details] [diff] [review]
"it's" fixes patch 4: docshell [landed 2009/02/05]
Comment 9 Daniel Holbert [:dholbert] 2009-01-22 09:14:37 PST
Created attachment 358192 [details] [diff] [review]
"it's" fixes patch 5: dom  [landed 2009/01/23]
Comment 10 Daniel Holbert [:dholbert] 2009-01-22 09:15:00 PST
Created attachment 358193 [details] [diff] [review]
"it's" fixes patch 6: editor folder
Comment 11 Daniel Holbert [:dholbert] 2009-01-22 09:15:22 PST
Created attachment 358194 [details] [diff] [review]
"it's" fixes patch 7: embedding [landed 2009/02/05]
Comment 12 Daniel Holbert [:dholbert] 2009-01-22 09:16:36 PST
Created attachment 358195 [details] [diff] [review]
"it's" fixes patch 8: extensions folder
Comment 13 Daniel Holbert [:dholbert] 2009-01-22 09:17:40 PST
Created attachment 358196 [details] [diff] [review]
"it's" fixes patch 9: gfx [mailed to cairo]
Comment 14 Daniel Holbert [:dholbert] 2009-01-22 09:22:17 PST
Requesting approval from module owners this time around, per comment 3 & comment 4. :)
Comment 15 Daniel Holbert [:dholbert] 2009-01-22 09:30:57 PST
Comment on attachment 358196 [details] [diff] [review]
"it's" fixes patch 9: gfx [mailed to cairo]

vlad -- these typo-fixes are all in gfx/cairo/cairo -- is it useful to make changes there, or does that just get overwritten every time we do a cairo upgrade?
Comment 16 Joshua Cranmer [:jcranmer] 2009-01-22 10:48:05 PST
Comment on attachment 358190 [details] [diff] [review]
"it's" fixes patch 3: db  [landed 2009/01/23]

Seems like McCusker doesn't know his possessive from his contraction...
Comment 17 Vladimir Vukicevic [:vlad] [:vladv] 2009-01-22 12:16:19 PST
Comment on attachment 358196 [details] [diff] [review]
"it's" fixes patch 9: gfx [mailed to cairo]

It gets overwritten.  But send the patch to the cairo mailing list, I'm sure it'll get taken upstream. (cairo@cairographics.org)
Comment 18 Daniel Holbert [:dholbert] 2009-01-22 14:53:22 PST
Comment on attachment 358196 [details] [diff] [review]
"it's" fixes patch 9: gfx [mailed to cairo]

(In reply to comment #17)
> But send the patch to the cairo mailing list

Ok, thanks -- I just sent the patch to the cairo list.
Comment 19 Daniel Holbert [:dholbert] 2009-01-23 01:23:58 PST
Landed patches #2, #3, #5 (for content, db, and dom folders):
http://hg.mozilla.org/mozilla-central/rev/c6dd3fd7c949
http://hg.mozilla.org/mozilla-central/rev/4d8381e446c4
http://hg.mozilla.org/mozilla-central/rev/edb61a05b485
Comment 20 Bill Gianopoulos [:WG9s] 2009-01-24 04:01:20 PST
(In reply to comment #2)
> Its great you took the time to fix these!
  ^^^
  It's

Was this intended as a joke?
Comment 21 Daniel Holbert [:dholbert] 2009-01-25 18:10:19 PST
(In reply to comment #20)
> (In reply to comment #2)
> > Its great you took the time to fix these!
>   ^^^
>   It's
> 
> Was this intended as a joke?

Ha! Dolske, you're a genius.  I totally missed that. :)
Comment 22 Daniel Holbert [:dholbert] 2009-02-05 18:08:05 PST
Landed patches #4 & #7 (for docshell and embedding folders):
http://hg.mozilla.org/mozilla-central/rev/b91945d3be91
http://hg.mozilla.org/mozilla-central/rev/00e5873f4641
Comment 23 Daniel Holbert [:dholbert] 2012-02-08 14:42:08 PST
Created attachment 595544 [details] [diff] [review]
"it's" fixes patch 6: editor folder (v2) [landed 2012-02-15]

Just noticed patch 6 in my bugzilla "my requests" page, awaiting review. :)

Updated patch to only include the chunks that still apply, and requesting review from an active /editor hacker.
Comment 24 Daniel Holbert [:dholbert] 2012-02-08 14:44:50 PST
Comment on attachment 358195 [details] [diff] [review]
"it's" fixes patch 8: extensions folder

(obsoleting patch 8, as its (ha!) patched code doesn't exist in m-c anymore)
Comment 25 Daniel Holbert [:dholbert] 2012-02-15 01:19:50 PST
Comment on attachment 595544 [details] [diff] [review]
"it's" fixes patch 6: editor folder (v2) [landed 2012-02-15]

https://hg.mozilla.org/integration/mozilla-inbound/rev/1db98753a46f
Comment 26 Daniel Holbert [:dholbert] 2012-02-15 01:24:39 PST
[this can be closed once that last patch is landed on m-c.  hip hip hooray.]
Comment 27 Daniel Holbert [:dholbert] 2012-02-15 01:24:59 PST
[er s/landed on/merged to/]
Comment 28 Marco Bonardo [::mak] 2012-02-15 09:17:51 PST
https://hg.mozilla.org/mozilla-central/rev/1db98753a46f

Note You need to log in before you can comment on or make changes to this bug.