right clicking and copy does not write to clipboard

VERIFIED FIXED in M18

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: raoa, Assigned: saari)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I am using build 2000071708.

Selecting text ,right clicking the mouse and copying doesnot write content to
clipboard. When paste is selected from the main edit menu it pastes the older
conents of the clipboard.

Right clicking to paste causes the paste option to be enabled after a copy but
when selected nothing happens and the option gets greyed out in both the main
edit menu and the right clicked menu.

To reproduce: Select text right click and select copy. place mouse some where
else on the test area and right click, select paste. Nothing happens and notice
that the next time you right click paste is greyed out in both the main and
right clicked menu.

Comment 1

19 years ago
COnfirmed with 071910 mozilla build on NT.  mozilla copies from the Edit menu
item and from ctrl+c but not from the context menu.
Assignee: asa → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: doronr → jrgm
(Reporter)

Comment 2

19 years ago
Confirmed on Solaris 2.8 sparc
Arun Rao

Comment 3

19 years ago
This is a dup of another futured bug.
Target Milestone: --- → Future

Comment 4

19 years ago
This causes a crash on my system:
Steps:

1. select text in browser
2. rt-click on selection
3. select Copy menu item
4. Copy menu item disappears from menu - but popup menu stays put
5. move mouse over menu
6. crash:

nsMenuFrame::SelectMenu(nsMenuFrame * const 0x0323690c, int 0x00000000) line 
428 + 23 bytes
nsMenuPopupFrame::SetCurrentMenuItem(nsMenuPopupFrame * const 0x03236848, 
nsIMenuFrame * 0x03236afc) line 887
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x03236a80, nsIPresContext * 
0x025f41f0, nsGUIEvent * 0x0012f824, nsEventStatus * 0x0012f714) line 385
PresShell::HandleEventInternal(nsEvent * 0x0012f824, nsIView * 0x0327be58, 
nsEventStatus * 0x0012f714) line 3996 + 38 bytes
PresShell::HandleEvent(PresShell * const 0x025f4ce4, nsIView * 0x0327be58, 
nsGUIEvent * 0x0012f824, nsEventStatus * 0x0012f714, int & 0x00000001) line 
3916 + 23 bytes
nsView::HandleEvent(nsView * const 0x0327be58, nsGUIEvent * 0x0012f824, 
unsigned int 0x00000008, nsEventStatus * 0x0012f714, int & 0x00000001) line 782
nsView::HandleEvent(nsView * const 0x0327b940, nsGUIEvent * 0x0012f824, 
unsigned int 0x00000008, nsEventStatus * 0x0012f714, int & 0x00000001) line 755
nsView::HandleEvent(nsView * const 0x032fcfe8, nsGUIEvent * 0x0012f824, 
unsigned int 0x00000008, nsEventStatus * 0x0012f714, int & 0x00000001) line 755
nsView::HandleEvent(nsView * const 0x025f4808, nsGUIEvent * 0x0012f824, 
unsigned int 0x0000001c, nsEventStatus * 0x0012f714, int & 0x00000001) line 755
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x025f45b0, nsGUIEvent * 
0x0012f824, nsEventStatus * 0x0012f714) line 1389
HandleEvent(nsGUIEvent * 0x0012f824) line 69
nsWindow::DispatchEvent(nsWindow * const 0x0327ba0c, nsGUIEvent * 0x0012f824, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f824) line 581
nsWindow::DispatchMouseEvent(unsigned int 0x0000012c, nsPoint * 0x00000000) 
line 3687 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 0x0000012c, nsPoint * 0x00000000) 
line 3894
nsWindow::ProcessMessage(unsigned int 0x00000200, unsigned int 0x00000000, long 
0x007c0021, long * 0x0012fba0) line 2787 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00800648, unsigned int 0x00000200, unsigned int 
0x00000000, long 0x007c0021) line 829 + 27 bytes
USER32! UserCallWinProc@20 + 24 bytes
USER32! DispatchMessageWorker@8 + 264 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsAppShell::Run(nsAppShell * const 0x00ed3f60) line 106
nsAppShellService::Run(nsAppShellService * const 0x00f1d258) line 387
main1(int 0x00000001, char * * 0x009374b8, nsISupports * 0x00000000) line 913 + 
32 bytes
main(int 0x00000001, char * * 0x009374b8) line 1093 + 37 bytes
mainCRTStartup() line 338 + 17 bytes

Comment 5

19 years ago
adding crash keyword
Keywords: crash

Comment 6

19 years ago
opened http://bugzilla.mozilla.org/show_bug.cgi?id=46005 for the crash part of 
this bug

removed crash keyword
Keywords: crash

Comment 7

19 years ago
->pinkerton, Is this another symptom of the 'stealing focus' issue, or should we
separately nominate for nsbeta3?
Assignee: trudelle → pinkerton
Target Milestone: Future → M18
i'm sure it's a stealing focus thing. clipboard hasn't been touched in months.
Assignee: pinkerton → saari

Comment 9

18 years ago
resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Summary: right clicking and copy doesnot write to clipboard → right clicking and copy does not write to clipboard

Comment 10

18 years ago
Works for Me
Platform: PC
OS: Windows 98
Mozilla Version: 2000100508

Marking as Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.