firefox ignoring browser.tabs.warnOnClose if browser.startup.page is set to 3

RESOLVED DUPLICATE of bug 419009

Status

()

--
critical
RESOLVED DUPLICATE of bug 419009
10 years ago
10 years ago

People

(Reporter: jesper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; da; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; da; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3

If using "Show my windows and tabs from last time", then we're not warned if we close multiple tabs (ctrl+q or close button likewise).

This is a very annoying "feature" if using ctrl+w and ctrl+a on a QWERTY keyboard.
If we have "Warn me when I close multiple tabs", why do we ignore it?


The bug may result in dataloss. 
Ex. tried to fill out a bugreport about this and pressed ctrl+q instead of ctrl+a resulting in losing all written text and having to relogin to bugzilla.

Reproducible: Always

Steps to Reproduce:
1. Set browser.startup.page to 3
2. Set browser.tabs.warnOnClose to true
3. Try to close with ctrl+q or the close button
Actual Results:  
Firefox closes

Expected Results:  
Firefox warns about you're about to close multiple tabs

Comment 1

10 years ago
I can confirm this bug (using Firefox on Windows).

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419009
You need to log in before you can comment on or make changes to this bug.